Skip to Content
0

How apply background De-active filter using Dimension Filter ?

Nov 17, 2016 at 05:37 PM

154

avatar image

Hi Experts,

Suppose I have a single data source name DS_1 and I applied DS_1 source to both chart and Crosstab as below,

When I selecting Year filter from Dimention filter only chart changed depends on year and crosstab don't change.

How to De-filtering to crosstab component.

thanks,

Sekhar

capture.jpg (66.4 kB)
10 |10000 characters needed characters left characters exceeded

I am not following and I cannot recreate this issue

Are you saying you filter only the chart filters, and not the cross tab? The numbers for California look the same to me.

Please also clarify, and share version of Design Studio

0
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Chandra Sekhar K Nov 17, 2016 at 06:15 PM
0

Hi Tammy,

Yes, filter apply only the chart filters and not apply to crosstab.

Design studio version 1.6

Thanks,

Sekhar

Share
10 |10000 characters needed characters left characters exceeded
Tammy Powlas
Nov 17, 2016 at 07:01 PM
0

Please share an image of your outline and properties of the application in Design mode

I can't replicate it on 1.6 SP2

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Tommy,

Please find following screen shots,

Outline,

App Properties,

Thanks,

Sekhar

outline.jpg (23.8 kB)
pro-app1.jpg (76.2 kB)
pro-app2.jpg (36.0 kB)
0
Mustafa Bensan Nov 18, 2016 at 12:54 AM
0

Hi Sekhar,

If your requirement is that you only want to apply the Year filter to the chart and not the crosstab as well, then you will need to duplicate the data source and assign the copy to the crosstab. The Dimension Filter should then only target the first data source which is assigned only to the chart.

Regards,

Mustafa.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Mustafa,

Thanks for suggestion.

I used duplicate Data source then application loading is very slow.

Thanks,

sekhar

0

Hi Sekhar,

Yes, unfortunately duplicating the data source will impact performance. However, I can't think of an alternative, more efficient approach to achieving your requirement. Is there a reason why the Year filter should only apply to the chart and not the crosstab? It would seem to me that for consistency of comparing the chart to the crosstab data, the Year filter should be applied to both.

Regards,

Mustafa.

0
avatar image
Former Member Nov 18, 2016 at 01:08 AM
0

you can set two datasource use the same universe,one is banding to crosstable,one to chart.and then set filter to datasource you want.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Jing

Thanks for Suggestion

Thanks,

Sekhar

0
avatar image
Former Member Nov 18, 2016 at 01:42 PM
0

Hi Chandra Sekhar,

For your requirement, you can do data selection in chart rather than filtering and show the crosstab without filtering.

Thanks,

Poovarasan

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Poovarasan,

As far as I know, the data selection option will only work for dimensions that are actually included in the data source Initial View. In Sekhar's example, the desired filter dimension, Year, is not included in the data source initial view, so I don't think the chart data selection option is applicable.

Regards,

Mustafa.

0
avatar image
Former Member Nov 21, 2016 at 07:43 AM
0

Hi,

Yes the year object have to be in rows are columns to use it in data selection.

But we can customize the crosstab using css to show only result of year right. Sorry if i confused you in my previous answer I have added my complete answer with screen shot

We can have initial view of data as in above image.

Then we can hide the columns not needed in crosstab and use data selection in chart.

The CSS i used to hide columns in my crosstad is

.sapzencrosstab-DataArea tbody tr td:NTH-CHILD(1), .sapzencrosstab-DataArea tbody tr td:NTH-CHILD(2),

.sapzencrosstab-DataArea tbody tr td:NTH-CHILD(3), .sapzencrosstab-DataArea tbody tr td:NTH-CHILD(4),

.sapzencrosstab-DataArea tbody tr td:NTH-CHILD(5), .sapzencrosstab-ColumnHeaderArea tbody tr td:NTH-CHILD(2),

.sapzencrosstab-ColumnHeaderArea tbody tr td:NTH-CHILD(3), .sapzencrosstab-ColumnHeaderArea tbody tr td:NTH-CHILD(4), .sapzencrosstab-ColumnHeaderArea tbody tr td:NTH-CHILD(5), .sapzencrosstab-ColumnHeaderArea tbody tr td:NTH-CHILD(1)

{ display: none !important; }


Let me know if anything need in it.

Thanks,

Poovarasan


initial-view.png (39.7 kB)
data.png (70.6 kB)
Share
10 |10000 characters needed characters left characters exceeded