Skip to Content

SAP BO4.x opendocument and SSO

We want to disable SSO for opendocument only. But for normal reporting access (like "http://xxx/CMC/BI"), SSO still works. Is there any easy way (no SDK) to achieve that?

We have checked the online help for opendocument properties, there seems to be not such setting.

Thanks in advance!

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Feb 18 at 08:59 PM

    In webapps\BOE\WEB-INF\config\custom, there are config files for each application. You should see files for BIlaunchpad.properties, OpenDocument.properties, and others. In each file you should see the settings for SSO; just remove the lines in the OpenDocument.properties file and that should do what you want.

    Add comment
    10|10000 characters needed characters exceeded

    • The settings may be in global.properties, in which case they apply to all applications. Check if you see this line:

      sso.types.and.order=

      If so, then you'll have to remove it from global.properties and add it to BIlaunchpad.properties. This will enable SSO for /BOE/BI only.

  • Feb 19 at 01:24 AM

    And the in launchpad. properties, we set

    authentication.default=secWinAD

    But, it still show "enterprise" each time when we try to log on CMC.

    Add comment
    10|10000 characters needed characters exceeded

    • upon successful login the browser will cache the last authentication type and will use that 1st then the default, clear browser cache and see if the default works.

  • Feb 19 at 03:54 AM

    When SSO is setup, usually we do it for one URL (with DNS name). The URL with server IP will work without SSO (that's how we have done).
    Try openDoc URL with server IP and see if that works without SSO.

    Add comment
    10|10000 characters needed characters exceeded