Skip to Content
avatar image
Former Member

How to update JSPM ?

Hi,

i'm currently applying EHP1 SP23 for SAP Solution Manager. For the Java stack it is said that i should update JSPM to at least version 7.01.2.1.1. I've downloaded the stack and tried to update JSPM using "Select a package type to apply -> JSPM". Unfortunately he told me that there is no valid update after scanning /usr/sap/trans/EPS/in although i copied all the files + stack.xml into it. Especially JSPM06_0-20002796.SCA and JSPM06P_2-20002796.SCA. I've updated SDM separately but that didn't change anything. Already search OSS and Google but didn't find anything. Current JSPM version is 7.00.14.

Any hints what's wrong ?

Regards

Update: I've installed the JSPM patch mentioned in Note 1145616; JSPM is now 7.00.14.3 but still no change. Deployment Tab -> JSPM shows no update found. Tried to update as Single Support Package as mentioned on help.sap.com but again no applicable update is found.

Edited by: Wolfgang Pungartnik on May 26, 2010 10:59 AM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    May 26, 2010 at 10:59 AM

    If you select the stack instead of the JSPM update function, do you see the JSPM update in the list then?

    Kind regards,

    Mark

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Mark,

      when i select stack i can see the complete stack downloaded from solution manager (SP23) including JSPM 7.01. I wonder if the update from JSPM 7.0 to JSPM 7.01 could only be handled by applying a complete stack. Updating from JSPM 7.00.14.0 to JSPM 7.00.14.3 was no problem.

      Regards

  • avatar image
    Former Member
    May 26, 2010 at 12:07 PM

    Hi,

    Nothing is wrong in the system. 7.01.* is a patch that will only be detected for a system which is already on EHP1. And since you are going to apply EHP1, JSPM will be upgraded in the process and you do not need to worry about this version right now.

    For now, it should be sufficient that you have updated JSPM within 7.00.* itself.

    Also, if you refer to the EHP installation guide, you will find that there is no step that asks you to update JSPM to 7.01 right in the beginning. So no worries for you.

    Regards,

    Shitij

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Shitij,

      thanks for clarification.

      I was confused by guide "Update to SAP Solution Manager 7.0 EHP 1 Using SAINT JSPM". On page 17 topic 5 it says "On the Deployment tab page, select the Java Support Package Manager option and update the software component sap.com/JSPM to the target SPS level.".

      Since my target SPS level is 7.01 SP23 i thought i have to update JSPM to that level before applying the rest.

      Well i'm going for the complete stack in one try and see what happens.

      Thanks !