Skip to Content
0

Recordset getting added by default in the payload

Nov 27, 2016 at 08:17 AM

57

avatar image
Former Member

Dear All,

The file I'm picking up has 3 structures: HEADER, ROW, and TRAILER. The <Recordset> tag is by default inserted in the beginning of the XML due to which the mapping is getting failed (as in the message structure, we have only header,trailer and row records). I am using File adapter and doing the content conversion.

Can you please let me know what should be done to remove the Recordset tag which is coming in the XML so that the message gets processed?

Thanks,

Amita

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Evgeniy Kolmakov Nov 28, 2016 at 12:37 AM
0

Hi Amita!

Use parameter ignoreRecordsetName = true in your FCC settings.

Regards, Evgeniy.

Show 6 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thanks Evgeniy for the response. We tried but it does not work.

0
Former Member
Former Member

Hello Amita,

Please post the FCC parameters used in the channel,Eve suggestion should work.

0
Former Member
Former Member

Hello Raghuraman,

Tried but it is not working.

fcc.jpg

fcc.jpg (52.6 kB)
0
Former Member
Former Member

Hello Amita,

Ok,Got it.MTB doesn't have this option,My bad,Try the approch in the below discussion

https://archive.sap.com/discussions/thread/3949816

2
Former Member
Former Member

Thanks a lot Raghuraman

0
Former Member
Former Member

Welcome Amit.Close the thread if your query is addressed.

0