Skip to Content
0
Former Member
Nov 02, 2009 at 12:11 PM

[XI 3.1] Infoview using old universe (or SQL) with Deski reports?

22 Views

We're using BO XI R3.1 SP2 and we're having a problem with refreshing Deski reports in Infoview. After updating objects in our universe, Infoview keeps showing us old definitions when refreshing the data!

Example:

1: In our universe, we made a new object "testobj" with a simple formula, for example " CUSTOMER.NAME || 'aaa' ". And exported it to the repository.

2: We then made a new report with Desktop Intelligence ("testrep1"), which simply shows a few objects, including "testobj". After exporting it to the repository, we used Infoview to view the report and it correctly shows the "aaa" values.

3: After this, we changed the object "testobj" into " CUSTOMER.NAME || 'bbb' " and exported it again to the repository. Refreshing "testrep1" in Desktop Intelligence (after using Tools - Universes - Refresh) correctly shows the new "bbb" values. When building a new Webi report (through Infoview), it also shows the "bbb" values. HOWEVER: refreshing "testrep1" in Infoview still shows "aaa"!!!!

4: To explore it a bit more, we also made another new report ("testrep2"), which first correctly showed the "bbb" values. Then exported it to the repository.

5: We modified the universe again, now with "testobj" as " CUSTOMER.NAME || 'ccc' ". Of course, also exported it to the repository.

6: Refreshing "testrep2" still shows the "bbb" values! And refreshing "testrep1" still shows the "aaa" values! Eventhough the universe now has the "ccc" values!

Does anyone also have problems with Infoview showing old definitions of data, after changing a universe?

We were first thinking that the system somehow still used an old universe. However, this would not explain the situation that "testrep1" shows "aaa", while "testrep2" shows "bbb". So, we're now thinking that the SQL is simply not regenerated. How can we solve this problem? We have full admin rights, so no security issues. We also tried everything to clear our cache in Explorer, but this didn't solve anything. Also tried restarting the server (and CMC servers), again no solution. Any ideas? Your input will be appreciated!