Skip to Content

Unable to Login to Development Infrastructure - login context could not be retrieved

Hi experts,

I am trying to log on to a Development Infrastructure and I get the error below:

An internal error occured during: "Logon to".
logon context could not be retrieved.

I can also confirm that the issue is with my local config for NWDS 7.5 only since my colleague can log in to the infrastructure using his personal workstation.

When we tried to use his credentials as well on my workstation, the same error appeared.

Below is the version of my Eclipse...

Any advise on what else I need to double check in my settings and config?

Thanks in advance,

Vey

nwds-version.png (12.8 kB)
error.png (11.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Oct 10, 2018 at 11:24 AM

    Hello Vey,

    I agree with Ervin. The change of the name server MUST be done on SLD level, and not in any settings (of any kind) of the NWDS.

    Please contact the SLD administrator to ensure the relevant SLD has this Name Server role.

    Please consider that ONLY one SLD is allowed to have Name Server role in the entire system landscape!

    Name Reservation

    Regards,

    P.S.: You have mentioned that even with the user credentials of your colleague, you have observed this error after re-logging. In case the Name Server is configured correctly, is it possible you have re-logged from different part of the network (f.e. where there is proxy server in place on the route between you PC and the SLD). Please consider that the NWDS is unable to connect to the SLD, when there is a Proxy on the way of the network communication. If this is the case I would recommend you to set bypassing the proxy, on the NWDS...

    1. Add the SLD host in the proxy bypass list by navigating to:NWDS - > Window - > Preferences - > General - > Network Connections.
    2. Switch "Active Provider" to Manual.
    3. Add the SLD host to the Proxy bypass list.
    Add comment
    10|10000 characters needed characters exceeded

  • Oct 09, 2018 at 03:59 PM

    Hi,

    Regards,

    Ervin

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Ervin,

      Yes, I am using NWDS.

      Please see below screenshot of what I get during startup.


      I am also able to ping the SLD:

      I failed to mention as well in the original thread that I am able to import a Development Configuration and Sync/Create Project for DCs - which means I am logged in during this time. It is when I log off (or turn off NWDS) and then log in again when I get the error.

      Not sure if it has anything to do with this as well, but I also modified the name-server-url inside the .confdef file of my workspace.jdi.

      This was needed as the original Name Server is incorrect (colleagues also did this).


      Thank you,

      Vey

      nwds.png (120.9 kB)
      sld-ping.png (3.1 kB)
  • Oct 10, 2018 at 10:55 AM

    Hello Vey,

    I am not sure that editing the local .confdef file is the way to go. Milen Dontcheff , Szabolcs Renyo , Zsolt Szunyoghy what do you say ?

    Cheers,

    Ervin

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 10, 2018 at 01:16 PM

    Hi Ervin, Milen,

    Thank you both for your help and suggestions.

    I will raise this to our SLD admin.

    But in terms of the issue raised, I was not able to encounter it anymore when I installed a new NWDS - SP8.

    I noticed my colleagues were using SP8 while I was still at SP7.

    No direct reason how it fixed the issue, but it now works well for me!

    Regards,

    Vey

    Add comment
    10|10000 characters needed characters exceeded