Skip to Content
avatar image
Former Member

BO 4.2 Clustering Issue - Rename the Cluster name

Hi Experts,I have the following setup
Windows 2012 r2
BO 4.2 sp02
clustering installation with 2 nodes (BOPROD1, BOPROD2)
Everything seems ok but I would like to change the cluster name so we are not only using the default first node
I went to CCM - change the cluster name with @BOPROD
Then changed in the D:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\warfiles\webapps\BOE\WEB-INF\config\custom the

BILaunch

old
# You can specify the default CMS machine name here
cms.default=BOPROD1:6400

new
# You can specify the default CMS machine name here
cms.default=@BOPROD


Also changed


PlatformServices

cms.clusters=@BOPROD
cms.clusters.production=BOPROD1:6400, BOPROD2:6400

I cannot login using the new cluster name @BOPROD but still can login with the old one

Am I missing anything?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

9 Answers

  • Oct 31, 2016 at 05:08 PM

    Can you have a look at the SAP note for how to change the cluster name for Business Objects using Web Application:

    1766935 - How to change the cluster name in the SAP BusinessObjects Business Intelligence 4.0 web applications

    See if you have missed anything. Also one suggestion, It seems to be odd but can you try login using IP Address or hostname of the BO server and if you can successfully login then log off. Then try to login using the cluster name.

    Also are you able to login to any client tool using @Cluster Name?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 31, 2016 at 05:21 PM

    HI,

    I see you have made the following changes,

    I went to CCM - change the cluster name with @BOPROD

    Change the cluster name to only BOPROD and don't prefix @ sign.

    Leave the other changes in the properties file as it is and then restart Tomcat and SIA.

    If the issue still persists then login with CMS hostname first to web apps i.e. CMC or BI Launchpad and after that you can login using cluster name.

    It can happen that the Clusterinfo.1400.properties file is not updated at times with the new cluster name that's why you are not able to login specifying the cluster name.

    Regards,

    Tanveer

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Tanveer,

      Thanks for you answer I tried as you mentioned and still have the same issue.

      Where do you think I can find this file Clusterinfo.1400.properties?

      Regards

      Ercole


  • Oct 31, 2016 at 06:49 PM

    Did you stop the SIA and go to CONFIGURATION Tab and change Cluster name, see below

    Regards,

    Ajay

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 31, 2016 at 08:10 PM

    You changed the properties files under warfiles - which is good because it means they won't be overwritten by an upgrade install. However, you also have to make the changes in the same place under Tomcat\webapps, then stop Tomcat and start it again in order for the changes to take effect.

    -Dell

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I have done in both locations tomcat and warfiles but nothing change.

      it's strange because I changed the cluster name but I can still login with the old name

      Regards

      Ercole

  • Nov 01, 2016 at 11:30 AM

    have you stopped tomcat, cleared tomcat cache, started tomcat ?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 02, 2016 at 10:08 AM

    Try

    @BOPRD:6400

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 02, 2016 at 04:50 PM

    Hi,

    You can find the clusterinfo.1400.properties file on windows under "c:/.businessobjects".

    Have you restarted SIA and Tomcat for the changes to take effect.?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 07, 2016 at 04:18 PM

    Thanks Tanveer and Everybody


    I found a solution as below

    Finally after couple of days of working, I managed to fix the clustering issue.

    Let me explain what I have done

    I.I stopped Tomcat and SIA Agent under the Central Configuration Manager

    I.Change the Cluster name to BOProd in both nodes

    I.Then I re-create the files under tomcat and under war files in both nodes

    D:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\warfiles\webapps\BOE\WEB-INF\config\custom

    D:\Program Files (x86)\SAP BusinessObjects\tomcat\webapps\BOE\WEB-INF\config\custom

    I.This time I added 3 files instead of two (I have read somewhere that there was another file involved)

    OpenDocument.properties

    BIlaunchpad.properties

    PlatformServices.properties

    The difference was that I put the full qualified server address in the PlatformServices.properties

    cms.clusters=BOProd

    cms.clusters.production=node1, node 2

    The difference I used BOProd without the @ symbol

    # You can specify the default CMS machine name here

    cms.default=BOProd

    I.After change these in both nodes, I re-deploy the entire website files using wdeploy (really took a while)

    I.Then I restart SIA Agent and Tomcat Agent

    After all of these it works using during the login in the system box @BOProd

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 03 at 06:25 AM

    Hi All,

    Can any one Explain here Step by Step BO Server 4.2 SP4 Clustering and Tomcat load balancing .

    Environment.

    CMS Database: Oracle 11g R2

    Windows Server 2016

    SAP BI Plateform 4.2 Sp4

    Regards,

    Muhammad Shafiq

    Add comment
    10|10000 characters needed characters exceeded