Skip to Content

The request could not be submitted for background processing

I am using ASP.NET 2.0 and CrystalXI to create a standalone report, which I am trying to show on my webpage using crystal report viewer.

The report is working in PULL model. It calls a Stored Procedure in the Oracle database ans shows the data. Has got few parameters. I am binding the parameters and the bind the report to the viewer. But the page shows me an error as follows:

"Error in File C:\DOCUME1\kangkang\LOCALS1\Temp\SAA_MISReportofDistributionTransformer {CA0BE8A7-533E-4D1F-A32A-ACAD93F4B54A}.rpt: The request could not be submitted for background processing"

I also created another report similar to this one. The only difference is that this does not have any parameter in the stored procedure. And this works fine.

I think there is an issue of loading the data, or passing on the parameters to the database.

It works fine with any other report that does not include any stored procedure.

Please help.

Thanks and Regards,

Kangkan

http://www.entity-solutions.com/

http://www.geekays.net/

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 21, 2008 at 10:39 PM

    That error comes up often when the structure of the data at runtime doesn't match the structure the report was designed with. Does your parameterized stored procedure change the data structure at runtime? If so, CR can't handle this. It has to retrieve data adhering to the same data structure each time the report is run.

    What happens when you connect to that stored procedure in the designer with the same parameter values which currently cause the report to fail in the application?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 21, 2008 at 01:52 PM

    Hi Kangkan,

    Back ground processing error is very generic error and having many different causes, so we need to narrow down the issue.

    Would like to draw the attention on some stored procedure points.

    • The owner of stored procedure must be of same group as the user (through which your DSN is created).

    Other possible causes of the error

    Permissions. When using web applications Crystal Reports requires at least read / write permissions on the user temp directory. Other permission issue should be investigated also. Use the utilities [Filemon|http://www.microsoft.com/technet/sysinternals/utilities/filemon.mspx] and [Regmon|http://www.microsoft.com/technet/sysinternals/utilities/regmon.mspx] to determine possible permission issues.

    Permissions. As the Error in File C:\DOCUME1\kangkang\LOCALS1\Temp\ try to provide the read permissions to this folder (for ASPNET in case of web application).

    Permissions. When using Windows Service. By default all Crystal Reports and Business Objects services will be started as local system, this is a built in account that has almost the same type of permission as a local Admin. This should be enough for local permissions. If the service is intended to schedule/send to a network path the service must be restarted running under a domain account and the path is the UNC path
    server\share not a share path like j:\share. E.G.; the service would be the server responsible for placing the file in the specified location. The account will need read/write permissions to the UNC path.

    Vista Operating System. Ensure that your version of Crystal Reports supports the Vista Operating System.

    Need more information about Version of CR and Visual studio and operating system and is the issue is on development machine or on production machine.

    Hope this help

    Regards

    Amit

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Kangkan Goswami

      The connection type shouldn't make a difference for that error - that error isn't specific to a type of connection. Whether you choose to use ODBC, OLEDB or a native Oracle connection is up to you. The connection type won't affect object ownership in the database. Whatever method you choose, the application will need the necessary credentials to log on to the database and retrieve the data.

      Did you use the same database credentials from the report designer that you are using from your application? Are you able to retrieve the appropriate data into a DataSet in the application with the same database credentials? If not, the report won't be able to, either.

  • avatar image
    Former Member
    Oct 13, 2008 at 02:31 PM

    Hi There, I am using Crystal Reports XI v2 on Windows XP in combination with Business Objects Enterprise on a Windows NT server and I had the same problem: Error in File C:\Filename.rpt: The request could not be submitted for background processing.

    I had never seen this problem before and I have a fleet of Crystal Reports running on the Business Objects schedule perfectly ranging in complexity from simple to straight out confusing. This one report was working fine if exported to PDF however as soon as I tried to export it using CSV format then either my Crystal Reports would die or the BO scheduler would return the above error.

    After searching a few forums I figured I should do some investigation of my own as this error potentially has multiple causes. I employed simple trial and error methodology. I generated the report in Crystal and saved the report file u2018with datau2019 so that when Crystal died I could open the report again and not have to rerun it (to save time). I started by u2018suppressingu2019 all the sections of the report except for the main section where all the data was contained and then tried exporting the limited report in CSV format and it worked. Thus the main section of the report was not the issue. One by one I unsuppressed each section and exported in CSV until I found the section which was causing the error.

    The cause of the error was the section with all my sub-reports (one of the eight sub-reports)! So I employed the same method as above (suppressed all sub-reports, then unsuppressed each one in turn and exported CSV file to determine which sub-report was causing the error). Once I found the single sub-report that was causing the error I noticed that some of the values my sub-report was producing were NULL values and I suspected this was the cause. I removed the NULL values from the sub-report, re-imported it into the main report (linking it using the same field) and proceeded to export the file in CSV format. I then saved the Crystal Report to the BO server and triggered the schedule in CSV format and everything worked out fine. Success!

    As it was all working I did not investigate further so do not know the true cause of the problem but I would advise trial and error investigation isolating different sections of the report to determine which is causing the problem, then either remove, replace or recreate this section.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 27, 2008 at 03:02 PM

    Same issue; .NET 2.0 Web App running on Window 2003 Server. Report works and exports in Crystal Developer. Many, many other reports working fine through this app and on this server. Seems to be bigger reports. Need a solution before the Crystal team gets taken over by the MSFT SQL Reports guys. As bad as SQL Report Server is this problem is killing the Crystal developersu2019 credibility fast. Management at my shop (big government) is in the process of reviewing the two reporting technologies....

    Edited by: Tyson Smith on Oct 27, 2008 4:03 PM

    Add comment
    10|10000 characters needed characters exceeded