Skip to Content
avatar image
Former Member

Allow public access REST Sender not working

I've created a REST Sender adapter and checked "Allow public access (no authorization required)".

The CORS value is set to "Allow all clients".

When testing the endpoint I'm getting a 401 in SoapUI

The url is http://sappo-hostname:50000/RESTAdapter/endpoint?parameter=value

If I log in or pass login credentials the service works.

My requirement is to have this endpoint to be publicly available without logging in.

How can I manage this?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Nov 01, 2017 at 05:23 PM

    what is your Pi version and sp?

    https://archive.sap.com/discussions/thread/3884041

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 03, 2017 at 02:22 PM

    Good question! I should have included this in the OP.

    We are at 7.31 SP19, which should be the equivalent of 7.4 SP16.

    Since the feature was introduced in PI 7.4 SP13, we should be ok?

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 20 at 12:14 PM

    Hi Everyone,

    I too face the same issue. Allow public access is enabled and Allow all clients option is chosen, but server still requires authorization. Request is failing with unauthorized error. Do any of you still face the same issue ?

    Regards,

    Nirmal

    Add comment
    10|10000 characters needed characters exceeded