Skip to Content
0

SFTP - interval (mSec) for modification check

Aug 24, 2017 at 07:10 PM

93

avatar image
Former Member

Hi Team,

In PO7.5, We had configured SFTP sender channel to pick files from SFTP. but while testing the Sender SFTP channel shows error as ' Modification check for <file name> failed. File will be removed from process list’.

So can you please let us know how to solve this issue.

Channel parameters: timeout (ms) -120000; poll interval -120; interval (mSec) for modification check -100; (tried with different probability's).

the file that we try to pick from SFTP has permissions like " -rw-r------ " . also let us know if we need any additional settings from file/file server/folder level.

Regards,prasanth

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Evgeniy Kolmakov Aug 25, 2017 at 08:13 AM
1

Hi Prasanth!

When modification check is being performed PI requests the file size from FTP server. So it's quite possible that you have unsufficient permissions to perform that kind of request. Another option might be (as mentioned in SAP note) that some FTP servers don't provide this information to client applications.

I would start with requesting the full access permissions for testing purposes. If the check is successfull - it definitely means that it's a permission problem.

Regards, Evgeniy.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Aug 25, 2017 at 08:17 AM
0

The error message would typically be shown if the last modified timestamp is changing over the course of two checks, so the file would not be polled for the current interval. Is the file you are trying to pol being updated constantly?

Have you tried increasing the timeout? At the moment it is identical to the polling cycle, so the system would only ever poll a file once.

Regarding the permissions:
Those would allow the file owner write and read access to the file and any member of the same user group read access only. That may or may not be sufficient for your scenario - try connecting to the server manually using the provided credentials and see if you can download the file.

Share
10 |10000 characters needed characters left characters exceeded