Skip to Content
0

Please help with SAP Hana installation

Jun 26, 2017 at 08:05 PM

129

avatar image
Former Member

Dear Experts,

I'm attempting to perform my first Hana installation.
I've installed the database (SPS12) without any problems.
Now I'm installing NetWeaver 7.4 over that Hana DB.
It shows the following since 2 hours:

Import Monitor jobs: running 1, waiting 27, completed 1, failed 0, total 29.

There is only one R3load running, causing about 25%-35% CPU load.
But nothing seems to be happening. The last logs in the installation directory
are exactly 2 hours old. This should have been loooong time done.
Also, I am not getting it why there is jobnum=16 configured and I have
only a single R3load process running ? i was googling a lot, but no
explanation, just that there is a problem with LOB loading in parallel, but
no suggestion on how to enable multiple R3load processes...

How do I check if something is happening ? And what shall I do now ?

Many thanks!

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

9 Answers

Hans-Hendrik Weise
Jun 27, 2017 at 05:54 AM
1

Dear Symon,

check what job is stuck, I mean which package is being processed by that one R3load job.
You can also upload import_monitor.log here and we can check this file, then drill down further.
Perhaps this KBA will help, too: 2146357 - How to analyze Migration Monitor issues in SWPM

Hendrik

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Dear Hendrik,

many thanks for your reply! Sure I'll upload the log in a minute, but the thing is, that I was checking a bit already,
and there is nothing, because the log is just 2 hours old and I think it doesn't represent what is (was) currently
going on.
I've had a similar situations before, while doing migrations and the solution was to simply wait for a long job to
end, but this was for big production databases. And I've never witnessed, that it will be necessary to wait 2 hours
for a job to finish for a simple installation of an "empty" new NetWeaver system.

Also, do you know, why only 1 R3load process started and not 16, as it should be ? Thank you, logs are coming
in a couple of minutes...

0

I'll wait for the files first, no speculation :)
Did you or your DB admin check on DB level what's going on? If it's only one job that hangs, maybe more detail we find looking there...<- I seem to drift into some movie related accent here *g

0
avatar image
Former Member Jun 26, 2017 at 09:08 PM
0

I have replaced R3load with the latest version and I have resumed it, but nothing more seems to happening, so I think it got stuck again :-(

PLEASE HELP ME :-)

Share
10 |10000 characters needed characters left characters exceeded
Prithviraj Rajpurohit Jun 27, 2017 at 07:53 AM
0

Hi

As suggested by Hendrik, please share the log files. (sapinst_dev.log and import_monitor.log) you can find these files in installer directory.

Also, please go through below link if that helps

https://wiki.scn.sap.com/wiki/display/SL/Troubleshooting+Installation+and+System+Copy+Issues

Regards

Prithviraj

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jun 27, 2017 at 09:55 AM
0

import-monitorlog.txtsapinst-devlog.txt

Hello and many thanks for your replies.

I had quite a hard time uploading the logs, due to the stupid limitations here.
You can find 2 of 3 logs attached here. The 3rd one is 5 MB, and the silly
attachment system here rejected a .zip.txt file as invalid file type, so I had to
upload it somewhere else and I'm providing a download link here.
Though I won't be surprised, if it then says - invalid link type :-D

https://mega.nz/#!E9kzHbTB!W3VeWU1OwvXktk-PuOqov-YMvXX6O6mIxwQTl8EItlU

Many thanks for having a look at my issue!

P. S.: In one of the logs, you can see, that it wasn't updated between 22:52h
and 0:45 - the time at which I interrupted everything as I decided that it makes
no sense to keep waiting for nothing - almost 2 hours.
MSSQL Server for instance, was making the whole Import ABAP phase in less
than 30 minutes on a much weaker hardware!


Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jun 27, 2017 at 10:47 AM
0

sapssexclog.txt

Pfff, OK, this feels a little embarrassing for me now... I could have thought of checking this log file as well... :-/
The thing is, that it hadn't been updated for sure. What you will see in the file, or at least most of it, must
have been flushed into the file after I have cancelled the entire operation. Otherwise I was constantly doing
ls -lart on the import directory and no file was updated for 2 hours...

Anyway, any advice on what this error is and how it could be fixed ? Many thanks in advance!


sapssexclog.txt (871.7 kB)
Share
10 |10000 characters needed characters left characters exceeded
Prithviraj Rajpurohit Jun 27, 2017 at 11:26 AM
0

Hi

It seems to me a network issue.

Could you please check sap note https://apps.support.sap.com/sap/support/knowledge/preview/en/2308459

and below thread https://archive.sap.com/discussions/thread/3858418

Regards

Prithviraj

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jun 27, 2017 at 12:53 PM
0

Hello Hendrik,

what you are saying is just partially true. I was checking the SAPSSEXC.log further.
It looks that it had been working fine, tables were created and objects imported. Till
I made the mistake to decide, that it's doing nothing and I interrupted it.
What you are saying then, is true - it was giving an error and I have checked the log
so I fixed it by using the following command:

R3load -merge_only SAPSSEXC.TSK

Then the import continued, but if I read the log correctly, it was then throwing the
10108 error - no idea why !!

However, what is initially suspicious here and nobody commends on it - why did I
have only a single R3load process, when I had set jobnum=16 ? Why isn't it doing
a parallel import ?

Many thanks!

Share
10 |10000 characters needed characters left characters exceeded
Hans-Hendrik Weise
Jun 27, 2017 at 10:21 AM
0

SAPSSEXC seems to be the faulty one. Can you please share SAPSSEXC.LOG (hope this works without hassle...)

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Done, see above pls.

0
Hans-Hendrik Weise
Jun 27, 2017 at 11:37 AM
0

Symon,

thanks so much for the speedy replies and uploads.
The SAPSSEXC.LOG shows an interruption of the import at June 26th, 20:00 local time.
At 22:43 it was attempted to restart the import but the necessary parameter for R3load
were not used thus the attempt failed. Same is valid for all subsequent tries to finish
import of this package.
Head over to KBA 1970577 and follow the steps in the Resolution section.

Let me know if that worked *thumbsup

Hendrik

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello Hendrik,

I've restarted it once more. Before that, I've done R3load -merge_only.
I still have no info what it's doing, as it's not updating any logs (at least
while running!)
I checked on another system which I've been installing a while ago (on
MSSQL Server) - REPOSRC has around 2.7 there. But STILL, 2 hours
should be more than enough to load such a thing.
I did a few more things:

R3trans -d:

R3load -testconnect - this works fine

I also tried to research something with hdbsql - for example, if I could
do a select on REPOSRC and try to see if the row count is growing, but
no much luck:

hdbsql=> \ds
Username: SYSTEM
Password:
* -10709: Connection failed (RTE:[89006] System call 'connect' failed, rc=111:Connection refused (localhost:30015))
hdbsql=>

I have tried to google that error, but I didn't find anything useful...

Hm, anyway... I checked while writing this post - R3trans -d was coming back with 0008, as it couldn't
identify table TADIR. But now it's coming back with 0000 and I've also seen that it has progressed A LOT:

Import Monitor jobs: running 3, waiting 1, completed 25, failed 0, total 29.

However, I'd once again like to ask you, why it's been importing with just one R3load process ? As now
there are obviously 3 running... Many thanks in advance!

0

Hi Symon,

what's the status now?

For the R3load job question, how many jobs were specified? If it was 16 as you wrote in
your initial post, it starts gradually and every 30 seconds (by default), migmon checks
the status anew and creates a new R3load job if necessary.

If REPOSRC is now the last package, SAPVIEW is the last one waiting but its import
will only start when all other packages were successfully completed. Thus, there will
also only be 1 active R3load job importing SAPVIEW.

Hendrik

0