Skip to Content
0

Could not open iView. The iView is not compatible with your browser, system.. with chrome

Apr 28, 2017 at 09:52 AM

1.4k

avatar image

I have gone through all the links and solution which are already there on SCN but I did not get solution for my issue with chrome browser.

This issue is occurring only on production , but on development system (both are on same version (7.31 EPH1 SP18) it is working as expected.

Also it works fine when I try to access SRM apps directly from federated SRM portal (7.01 SP08) url.

We have XYZ as entry point(main) portal (version 7.31 same as dev) and having SRM apps (federation to SRM portal).

When i try to access any of the SRM apps (standard ivew copied in roles) I am getting this error "Could not open iView. The iView is not compatible with your browser, operating system, or device".

Could it be somethings related to federation ?

Could you please help and suggest what needs to be checked.

P.S : I have checked user agents and all it is OK and all the Iviews properties are same as Iviews in Development system where it is working fine.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Santarshi Samanta
May 01, 2017 at 09:37 AM
2

Hi Akshay

As you have mentioned that you have gone through all the links and solution which are already there on SCN. Can you please check once if you have gone through the below documents and followed the steps given for resolution or not.

2266579 - Could not open iView in Chrome on launching portal

https://blogs.sap.com/2015/11/30/the-error-could-not-open-iview-the-iview-is-not-compatible-with-your-browser-operating-system-or-device/


Regards

Santarshi Samanta

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Santarshi,

Yes I have gone through this blog as well but no success.

As i have mentioned, it is working on our development environment, but the problem is that, it is not working on Production portal.

This is not related to any particular IVIEW .This error is for all SRM related applications (application consuming from federated SRM portal) . If i try to access those SRM apps from SRM portal itself, then apps are working as expected hence concluding there is no issue with SRM apps.

I have compared each and every property, all settings and parameters(useragents as well) are same. Also i have compared patch level, patch level is also same.We also tried restarting the production portal but still same error.

0
Troy Cronin
May 03, 2017 at 01:30 PM
1

Hi Akshay

Firstly I hope you are keeping well and many thanks for using the SAP Discussion Forums on SAP Communities.

Surrounding your scenario and the problem description my colleague Santarshi's reply is indeed of vital importance in this instance as the documentation outlined is a core means of resolution.

From your follow on clarifications you mentioned the issue is within only the Production Portal (Dev is fine).

  • Have you reproduced the behavior and cross-referenced the latest default trace file to see if there are any Portal references thrown within the trace in assoication to the Production Portal?
  • SAP KBA: 1596214 - How to find the latest default trace file of the NW AS Java right after reproducing an issue

I have seen similar occurrences to this in the past which led to the generation of the following documentation:

  • SAP Note: 1666862 - Allow other browsers to access the portal

The note documentation is for NW 7.31 releases and below and has resolved multiple discrepancies in the past with different Web Browser Platforms.

Older reference threads on Communities also referenced such an occurrence:

Portal 7.02 SP6 on Google Chrome throws error.

http://scn.sap.com/thread/2080155

NWP 7.3 other browser support (google chrome)

http://scn.sap.com/thread/2140872

Kindly update me as per your findings

Troy Cronin - Enterprise Portal Support Engineer

Share
10 |10000 characters needed characters left characters exceeded