Skip to Content
0

Error in Sales Order Create :- message 00002 Invalid Data

Apr 21, 2017 at 09:23 AM

224

avatar image
Former Member

SAP Error: 00-002

Desc: Enter a valid value

Internal: 1

I have tried with many Sales orgs too and get the same error message -

I have tried creating with reference from an existing sales order, still same error message.

I have checked all other config related to this area and it all seems ok to me

Program being executed is SAPMV45A - has a user exit or BAPI been installed that is preventing me from proceeding ?

I have been able to create orders in the past, this has just occurred in the last week or so

any ideas would be much appreciated as I am totally stuck

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Veselina Peykova
Apr 21, 2017 at 09:56 AM
0

Generic suggestion:

In such cases I would either place a break-point at the message to see where the error is raised or I would check for recent transport requests.

Questions, which might help you figuring out what is going on:

Have you noticed at which point exactly the error is raised - when you enter a customer, when you enter a material, when you reprice, when you add/modify a condition, when you save?

Did you try also with orders, resulting in a different pricing procedure (preferably a standard one)? What about different order types and item categories?

It is very hard to suggest anything more specific considering the available information.

Share
10 |10000 characters needed characters left characters exceeded
Jürgen L
Apr 21, 2017 at 11:15 AM
0

If that has "just occurred" then you should ask your IT to check which changes have been transported into your system.

Transaction ANST can also be used to analyze the transaction, it will also show exits and modifications.

Are you the only one in your organization who creates Sales orders? Are others not affected?

Not being able to create sales orders would classify as major incident in our company and the alarm bells would not calm down until the error is solved. Someone in your local IT should be able to find the recent transports by using SE10 transaction

(Coincident or you work in the same company with this guy: https://answers.sap.com/questions/180348/erron-in-va01.html )

If this is really a new bug then it should as well be possible to find the root cause by checking recent updates/changes/transports/notes implementations ,asking colleagues and supervisors.

Share
10 |10000 characters needed characters left characters exceeded