Skip to Content
-1

Error In VA01

Apr 18, 2017 at 05:37 PM

104

avatar image

while entering customer number in sold to party it says enter valid data. I have done all the required configurations. please assist.

Error in VA01: Message 00002 'Enter a valid value'

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Jürgen L
Apr 18, 2017 at 09:04 PM
1

00 002 is not a SD related message, message class 00 belongs to Basis

Sales document related messages have the message class V1

As there are also no OSS notes and no questions with the combination of message number and transaction in the community and based on the above mentioned facts I strongly believe that this message has its origin in own coding.

Show 3 Share
10 |10000 characters needed characters left characters exceeded

I doubt it. I think I am missing something in Partner Determination Procedure. (T code - VOPAN ). Please assist.

0

Then you should explain what you did in customizing

0

Created 4 Account group assigned 4 Partner determination Procedure AG, WE, RE, RG . Created 4 partner functions SP,SH,BP, PY assigned to respective PDP. Assigned account group to partner Function & Partner determination procedure. Same for Sales Document header, assigned PDP to sales document type.

0
William Singh Apr 18, 2017 at 09:26 PM
1

It looks like basic determinations like pricing might not be working properly. It could be due to new definitions/ updates.

You can derive some hints from this note '2426542 - Error 00002 - Enter a Valid Value thrown during implementation of note 2410105', although this note is not directly applicable.

BR, William

Show 3 Share
10 |10000 characters needed characters left characters exceeded

I have set the pricing procedure for the given sales area (OVKK) . I doubt i am missing something in partner determination. Whenever I enter transaction VA01 already I get a numeric value in sold to party field (2000). I enter created customer in Sold to party it says invalid whereas when I enter in ship to party it depicts the sold to party. Further When I enter my material number along with quantity the cursor again goes back to sold to party saying Invalid value.

0

I would suspect either a transaction variant or custom code gone wrong...

The only standard functionality, that I can think of, where you have a sold-to party entered, but you are still asked to enter a sold-to, is when you have KNA1-DEAR5 = X, but it does not get defaulted all by itself, the messages are different and you get incompletion log.

In your case, pre-defaulting can be either a transaction variant (check also VOV8) or custom code in partner determination user exits or even something shady going on in MV45AFZZ.

As Jürgen already pointed out, the most likely cause is custom logic, developed by your project team colleagues. The most efficient way would be to check the available project documentation, or ask your colleagues. If there is no up-to-date documentation and no helpful colleagues, you can try to debug and find from where the logic is triggered.

***Edit***

I had to retype my response again - the original message disappeared after submitting. Wasn't this bug fixed already?

1

Created 4 Account group assigned 4 Partner determination Procedure AG, WE, RE, RG . Created 4 partner functions SP,SH,BP, PY assigned to respective PDP. Assigned account group to partner Function & Partner determination procedure. Same for Sales Document header, assigned PDP to sales document type.

0