Skip to Content

Import File Deletes the Input Form Data

Hi Experts,

We noted that when importing a data file it deletes the input form data for the same category entity and time.

In the NW version there's also an AuditID (Datasource) segmentation for import, that allows a user to input to forms in one AuditID and and import data to another such that input form data is not deleted. This allows the users to constantly re-import their data (after corrections) without losing their input form data.

Any ideas for a solution in the MS version?
One manual solution is to import to another category (e.g. ACTUAL2) and then create a specific copy package from ACTUAL2 to category ACTUAL where the input form data resides, copying only the specific AuditID. This creates another step for the users.

Maybe automate the above option and add to the default script a copy statement that copies the above a when auditid = INPUT (the AuditID of the data) and not affecting the input form AuditID level.

Any other ideas?

The current setup assumes that the user will only enter input form data after completing the data import. This is not always the case. There are several import iterations.

Thanks in advance

Eyal

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    May 05, 2016 at 10:34 AM

    Hi Roberto, and Arnold

    Is there another option to change the import Data Manager package such that the combination of replace and clear will be CATEGORY ENTITY TIME and AUDITID?

    I see a variable %CLEARDATA% in the Data Manager script.

    Can we populate that or similar and obtain the desired result? If so what's the syntax?

    Thanks in advance.

    Eyal

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 18, 2016 at 07:33 AM

    Hi Eyal,

    For one of our clients we have created a specific clear package, that the user can run prior to a re-import. It is set to only clear imported data (specific datasource). The import then uses the add/replace rather than the clear option.

    You could even add these two into a package link to be run together (one after the other).

    BR,

    Arnold

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 18, 2016 at 12:16 PM

    Hi Eyal,

    yes your right the clear option inside the package deletes all the data for the same category entity and time.

    If you need to filter better the data to delete as Arnold wrote you can add a package that contains a *CLEAR_DESTINATION restricted with your definded scope.

    Regards

    Roberto

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks Roberto and Arnold.

      Thank you for the quick response.

      I was discussing the point with a colleagure this morning.

      This is what we will setup.

      Will keep you posted.

      Regards,

      Eyal