Skip to Content
avatar image
Former Member

Fiori Language when using SAML

Hi We were able to select language on Fiori logon screen and able to see the translated texts in the Fiori launch pad and the applications within. In this scenario Logon is through basic authentication with the same user existing in Front end Gateway server and backend ECC. We were able to configure SAML2 authentication with a third party IDP with Fiori and was working successfully. SAML is one of the recommended authentication mechanisms supported. So the issue is now using both of the above together (Languages + SAML). When we configure SAML authentication we will be redirected to Identity Provider’s logon page and not the Fiori logon page. In this scenario there is no way for Fiori application to pick up user’s language or for the user to select his/her desired language in Fiori. This issue of language along with SAML can be resolved in desktop browsers by setting browser language, but doesn’t work on mobiles and when using Fiori Client. Even device language is not being taken for displaying Fiori content. So how do we make the multi language work for Fiori when using SAML authentication? Thanks Vidyadhar

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Nov 10, 2015 at 10:41 PM

    Hi Vidyadhar,


    Did you ever find a solution for this? We are using SAML with an IDP as well and would be interested on how to get this to work.


    Thanks!

    -Kevin

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Kevin

      We got it working finally. Configured Gateway to authenticate with CA Site Minder as Service Provider using SAML.

      Thanks

      Vidyadhar