Skip to Content
avatar image
Former Member

IDoc receiver channel: connection factory name for channel is null

Hi,

This is related to Production Support. ECC system was planned to maintenance shutdown.

Before ECC is down, I have stopped all PI communication channels (first all sender channels and then all receiver channels) using mass stop from PI MON.

After ECC was back up again, I have started the PI channels in reverse order (receiver channels first and then sender channels). All the channels were up and running fine except IDoc receiver channel. It was showing below error:

IDoc: connection factory name for channel IDOC_RCV_ECC is null

Start and stop of the channels was not not helpful.Then PI system was restarted, post which IDoc receiver channel was up and running fine.

Does anyone have any idea on root cause of this issue? What can be done to resolve this without system restart.

Thanks,

Vertika

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Dec 30, 2014 at 09:04 PM

    Did you test the "Destination" in NWA before restarting the PI system?

    If that didn't had any issues, instead of restarting the PI system, you can/could have tried restarting outbound RA(Application).

    As the issues has already resolved now, it's difficult to find root cause.

    However if it reoccurs you can try channel ping/xpi inspector to capture additional details before restarting PI system.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Harish,

      Am also facing similar issue but here I route the channels from QA to RE. I created new destinations which pointing to RE and configure JCO settings. After this am getting this error. Any inputs on this will be helpful