Skip to Content
0
Jul 17, 2013 at 01:37 PM

ComponentConfiguration, FPM Event ID not editable

300 Views

HI all gurus,

a tricky question here, to test your skills :-P

Shortly; We created a Custom Component Configuration by copying an existing standard one (/SAPSRM/WDCC_FPM_OIF_RFQ_PR_PU).


The problem: after a lot of work on it, we realized that the Standard Configuration we took as source for the copy was "broken"... In this sense; there was an FPM Button which has been hidden and - here's the point - the FPM Event ID was a wrong one (specifically, FPM_PRINT_PREVIEW instead of PRINT_PREVIEW).

So... now we have a Custom, used Component Configuration in which the standard button "Print Preview" does not work.

We should simply fix that "FPM Event ID" parameter in order to adjust our configuration, but we cannot, as you can see, because the InputField is in READ-ONLY state:

So....

....there apparently no way of fixing it. The only solution possible should be:

- recover the original Component Configuration to the standard version;

- re-copy it;

- move to the new Configuration all the custom modifications done in our "broken" Zconfiguration.

You certainly understand that this is quite a time-wasting activity as all we need is to bind the button to the standard PRINT_PREVIEW event.

Is there any approach or workaround you can suggest us to achieve our task?

So far, I tried to open that field in debug :-P and yes, I got it, but once the SAVE button is pressed, then the inputField is set again in read-only state and with event "FPM_PRINT_PREVIEW".

Maybe there's a "backdoor" way to fix it ... I tried exploring the WDY_CONFIG_DATA but here configs are stored in RAWSTRING format so it's probably impossible to fix & replace the entry for my custom configuration.

Any help will be highly appreciated 😉

Attachments

Capture.JPG (166.2 kB)