Skip to Content

Sender structure XXX does not exist: Error status on Outbound side

Hi Experts,

My scenario is ABAP Proxy (SAP SNC) to IDoc (SAP ECC). We are using standard content SNC 7.0 in ESR. The Target IDoc is 'PORDCH.PORDCH02' which is not uploaded in ESR as Imported Objects (Just using the IDoc name, namespace & SWCV) and it should not be any problem because we are using Java Mapping (Standard Content by SAP). IDoc metadata is already refreshed and Cache refresh is performed.

We are getting "Message has error status on Outbound side" in SXMB_MONI for this particular interface 'ReplenishmentOrderNotification_Out'. All the other Interfaces using Standard Content from SNC to ECC are working fine.

We have checked SM58 and the error is 'Sender structure ZSNC_PO does not exist'. Now "ZSNC_PO" neither exist in Sender ABAP Proxy structure nor in Target IDoc structure. I have checked ABAP Connection and tested successfully in SM59 of PI.

We are facing this issue only QA. DEV and Prod are working fine. All the ESR and ID objects are identical across all the environments.

Also the IDoc did not reach SAP ECC. I have checked WE02 in ECC and there is no 'PORDCH.PORDCH02'.

Any inputs would be appreciated.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on May 29, 2013 at 09:15 PM

    Since this is happening only in QA not in other environments, Please see the data coming from the sender system and test the same in DEV to make sure the problem is not due to incoming data. This does not seem caching issue. Is your QA environment is same version sp that of other boxes?

    .

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Baskar,

      Thanks for the reply.

      I have just pushed the QA data to DEV system and it get processed successfully in PI as well as in ECC. As I mentioned before there is nothing called "ZSNC_PO" in Sender / Target Structure or Data. I have also compared Version and SP level for DEV / QA / Prod. All are same. This is really strange.

  • Posted on May 30, 2013 at 01:53 PM

    Any one has any other thoughts?

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Nabendu,

      Compare the metadata of the IDoc in PI and Receiving SAP system. Try deleting the metadata from idx2 and re-import it again. While deleting make sure that the port (in idx2) under which you re-import should be same as the one given in IDOC receiver adapter.

      Regards

      Suraj

  • author's profile photo Former Member
    Former Member
    Posted on May 31, 2013 at 11:19 AM

    Have you registered the queues?

    SXMB_ADM - register queues . Could you pls cross verify.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.