avatar image
Former Member

SOAP Service could not be loaded: XMLProxy Error: The markup in the document following the root element must be well-formed

Hello all,

In MII14.0, I'm trying to import a SAP PI WSDL into either a web service XI or a web service action block, both yielding the following error:

"SOAP Service could not be loaded: XMLProxy Error: The markup in the document following the root element must be well-formed"

Here are the steps I followed:

1. Upload the PI WSDL to MII as web content. (The service has not been published to a UDDI, so I had to upload the WSDL file to the web content section of MII.)

2. Using either the 'Web Service' or 'Web Service XI', I specify the MII URL path to the file uploaded in step 1.

3. After clicking next, I get the error above.

I can successfully view the WSDL in a browser and have imported it into SOAPUI without any issue.

Can anyone shed some light onto this?

Thanks,

--jtb

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    May 12, 2013 at 02:45 AM

    Try the same URL in an xmlloader and trace the results - the error could indicate non-XML results (like a login screen).  If the URL you are using in the config dialog needs a proxy server it would likely work ok in a browser test, but MII needs the proxy settings in the system config settings.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 27, 2013 at 07:52 AM

    Hello James,

        As Jeremy mentioned in the above reply, this error comes when the response is something other than a normal XML. May be you are getting a login-screen. Some wsdl's require credentials at design time too.

      Try passing in the credentials and then click on the NEXT button. It should work.

    Regards,

    Tufale Ashai.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 28, 2013 at 01:48 PM

    Hello guys,

    My apologies for not responding sooner, but I was able to figure the problem out on my own. I found I needed to use the web:// prefix when referencing the wsdl path in the action block. I suspect it was because of credential issues, and a html page rather than an xml one was being returned to the action block.

    Thanks to both of you for your help.

    Regards,

    --jtb

    Add comment
    10|10000 characters needed characters exceeded

Skip to Content