Skip to Content
0
May 09, 2013 at 07:03 PM

4.0 Web Custom Properties Aren't Being Used

60 Views

I am in the process of configuring a BOIP 4.0 SP 5 Patch 7 system for a client. The system has two clustered CMS/app servers and two separate web servers behind a load balancer.

On the web servers, I've set up some custom properties files to do things like set the cluster information, show the Authentication drop-down on the BILaunchpad login screen, etc. Here's the contents of the BILaunchpad.properties file

authentication.default=secEnterprise

authentication.visible=true

cms.default=@BOE40DEV

cms.visible=true

The files are located in the WebApps\BOE\WEB-INF\Config\Custom folder of both the Tomcat6 and SAP BusinessObjects Enterprise XI 4.0\warfiles folders.

After creating the files, I stopped Tomcat, deleted the Tomcat6\work\Catalina folder, and restarted Tomcat.

The updates I made to set the cluster information in the Custom PlatformServices.properties file do seem to be working as I am able to log in to the cluster instead of going to a specific server. However, when I go to BILaunchpad, the Authentication drop-down is not appearing on the login screen unless I go to the Default BILaunchpad.properties file and change authentication.visible there.

I saw this situation with another client recently, but only on their Dev system - QA and Production worked correctly. My concern is that when this happens, I've also been unable to get manual AD authentication working for the server. I still have to configure AD authentication for my current client, so I'm not yet sure if that's the case here.

Has anyone seen this before and is there something I can do to get this working? Thanks!

-Dell