Skip to Content
avatar image
Former Member

Urgent -ITS Problem


We have Implemented Integrated Windows Authentication. We have problem in accessing the URL. We are using IISPROXY 1.6 in Windows 2003 env.

Below is snippet of our IISPROXY.XML code...

<mapping name="IisProxy samples" use-continue="true" >











<compress-types>text/html, text/plain</compress-types>


when i try to access the portal by typing the url as http://<webserver>:<port>/vasu it is redirecting to http://<webserver>:<port>/irj/portal but i am getting "page cannot be displayed" error. Any Idea abt this.



Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Aug 30, 2005 at 07:27 PM

    Hello Vasu,

    first of all: I think you should post this call to one of the WebAS/J2EE forums.

    I although had the same sort of problems, I will try to recall them, they may be of any help in troubleshooting.

    • from your XML I see one point of interest: you are writing the <prefix>/vasu without a slash at the and and the <new-prefix>/irj/ with an ending slash.

    • I first checked the logfile(s) and the webserver logs

    from the logfile:

    20:21:39 Filter J2EE --> GET /Hello/

    from the webserver log:

    20:21:39 GET /iisproxydir/IisProxy.dll/Hello/ 404

    • I put the loglevels to the maximum i.e.

    log-level "3"

    log-flags "-1"

    debug-flags "-1"

    for the Filter, Extension and Mapping.

    • Then I watched the logs again:

    And there were Initialisation problems

    20:39:44 Global E-Init IisProxy Extension initializing.

    20:39:44 3604 E-Init W SapInit(): SapSSLInit() failed: -1 (SSSLERR_LIB_NOT_FOUND)

    20:39:44 3604 Map d Mapping::Init( IisProxy samples )

    20:39:44 Global E-Init IisProxy Extension initialized.

    20:39:44 3604 Config IisProxy Extension configuration:

    After setting the right paths for my cryptolib and pse files it worked for me.

    I also fooled around with the access rights for IUSR in the IISProxy directory and the IISProxy.dll but I cannot recall what I did exactly.

    (remember to set back the loglevels afterwards)

    Kind regards,


    Add comment
    10|10000 characters needed characters exceeded