Skip to Content
0
Former Member
May 08, 2013 at 12:50 PM

Deploy an UFL

241 Views

Hi!

I programmed an ufl using Visual Studio 2012 (VB). I use this ufl in a report for a website that was also programmed with Visual Studio 2012. I am able to run the website on my developpement PC without problem. But when I try deploy it on another computer, it does not work. Both computers run on Windows 7 64-bit. I don't know why but, after a whole day of trying to solve the problem, I have been able to make it work on a computer with Windows server 2008 R2 64 bit. But now I am trying on the Win7 64 bit computer without success.

I did the procedure shown on the link:

http://wiki.sdn.sap.com/wiki/display/BOBJ/How+to+deploy+a+UFL+created+in+Visual+Studio+.NET

I use IIS and my website is configured to use the framework 4.0. The source code is built on the framework 4.5.

I installed the redist for Cystal Reports : CRforVS_redist_install_64bit_13_0_5

When I try to show the report with the UFL, I get the error message :

UFL u212com.dll that implements this function is missing [...]

The reports that are not using UFL are working.

I searched on google and tried everything I've found. I tried to register the ufl with gacutil, also with regasm. The ufl folder does show in the GAC : C:\Windows\Microsoft.NET\assembly\GAC_MSIL. I tried to build both projects (ufl and the website that use the ufl) in 32 bit, 64 bit or any cpu and registering the ufl so that it shows in the 32 bit and 64 bit folders of the GAC. Nothing works (but on the Windows server 2008 machine, it is built in any cpu). On the working machine (win 2008), I tried to delete by hand the ufl in the GAC, when I delete the one in GAC_MSIL, it stops working. But if I delete the ones in the 64 bit and 32 bit folder, it is still working. So my guess is that when I build using the any cpu option, it takes the ufl in the GAC_MSIL folder. I also rebooted my machine everytime I tried something new.

I also installed the 32 bit redist of Crystal Reports, nothing changes.

As for u212com.dll, it is in the Crystal Reports folder :

C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win64_x64

I tried so many things that I lost track of what I did, so maybe I forgot some details.

Does someone have an idea of what would be the problem?

Thanks!