Skip to Content
avatar image
Former Member

Prevent PO to populate price from last po price

Hi Expert,

In purchasing info record, I have this condition:

Valid from 15.04.2013 to 30.04.2013

PB00 : 1 USD

The price is not available yet for May.

I want to have the result like this:

When I create PO with exactly the same vendor, material, plant and purch.org, but the PO date is 01.05.2013, I want the system to block the PO since the PO date is not met the validity date in info record.

I know this is the standard, but the problem is :

I forgot to remove the check-mark in info-update field in my last PO, so when I create PO with exactly the same vendor, material, plant and purch.org, but the date is 01.05.2013, the system populates the price from the last PO.

This condition causes the PO to get the wrong price.

Since then, every time I create PO, I remove the check-mark in info-update field, but I still don't have any idea how to prevent this PO from populating the last PO price, if the validity period is not met.

Please help.

Best regards,

Amri

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

6 Answers

  • Best Answer
    avatar image
    Former Member
    May 07, 2013 at 10:13 AM

    Hello,

    Refer this path:

    SPRO --> MM --> Purchasing --> environment --> define default values for buyer --> Price adoption --> select 'do not copy 'option.

    For info record update .. refer same path --> goto indicators --> you can select option under 'info record update'

    Hope this will solve your problem..

    Regards,

    Priti

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 07, 2013 at 10:19 AM

    Hi Amri,

    In addition to Priti's answer, this setting can be done userspecific with parameter EVO.

    You can create your own setting for "dafault values" and assing EVO parameter to user id with default value.

    Regds,

    Nilesh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 07, 2013 at 10:19 AM

    Hi Mahfudz,

    You can control it by making changes in given path: IMG-MM-Purchasing-Environment-Define Default Values for Buyers-Setting for Default values-In Price Adoption Tab tick option "DO NOT COPY"

    Try this and let us know.

    Regards,

    Anoop Singh

    Add comment
    10|10000 characters needed characters exceeded

  • May 07, 2013 at 06:53 PM

    Hi,

    The simple solution could be , alsong with inforecord do you also have source list ? If so you can use that . Wwhile you create PO , sustem will stop if the dates are after the validity .

    also , you can always overwrite the PO value with a new value , even the price is defaulted , with the new price you check the infoupdate indicator then new price will be coming into the last PO .and this price will get defaulted .

    For such cases SAP always suggests to have a aggrement in place for the prices ..

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

  • May 08, 2013 at 04:27 AM

    Hi,

    Check during creation of purchase order- any purchase info record number triggers,if yes-Set Flag for Deletion for that info record number in t.code: ME15 and save.

    Now create a new purchase order with ME21N and see the difference!

    If needed, you can deactivate automatic info record update in purchase order by referring a thread which already discussed:

    http://scn.sap.com/thread/3188717

    Regards,

    Biju K

    Add comment
    10|10000 characters needed characters exceeded

  • May 08, 2013 at 05:00 AM

    Hi,

    In addition to Bijay, kindly check info record at various level, may be created on Purchase Organisational level or Org+Site level, check info record is coming in PO from where. Just double click on info record will show you. Sometime EINA/EINE table not update properly. Check that info record in me12, is it changeable. Check also condition record in MEK3 or MEK2

    Regards

    Sanjeet Kumar

    Add comment
    10|10000 characters needed characters exceeded