$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: true, vro: true, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content

incomplete structure issue with FILE to IDOC scenario

Hi experts,

we are working on FTP to IDOC scenario. i have to pick CSV file from FTP server.

im facing the issue  "" Format error in 'xml.recordset' argument: incomplete structure (name,number) pair ""

i have referred the following blogs but i didn't find any resolution for my problem.

http://scn.sap.com/thread/232703

http://www.riyaz.net/sap/xipi-file-content-conversion-for-simple-structure/75/

i have verified the mapping and the FCC parameters correctly. but still it is showing the same issue. and the CC channel is showing inactive.

i have tried to make inactive and activate it again. and i have checked the locks. everything is fine.

For Begin, Segment i have passed the constant " 1"

FCC parameters

so let me know if im wrong. stuck with this issue, waiting for quick reply..

guide me to resolve this issue.

thanks in advance for your help..

Mapping.png (42.6 kB)
FCC.png (25.0 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    May 03, 2013 at 05:38 PM

    Hi Bhargav,

    Alter your Data type structure and remove 'row' from data type ,dont specifiy record set name and add

    ignoreRecordsetName true.

    attach csv file here.

    Regards,

    Raj

    Add comment
    10|10000 characters needed characters exceeded

    • Ambrish Mishra Bhargava krishna Talasila

      Hi Bhargava,

      Please check some things...

      In PI

      • the business system of PI has got logical system associated with it in SLD.
      • If yes, put PI business system as sender component in the receiver agreement under header mapping.
      • Open the business system in ID and check if Adapter specific identifiers are there else replicate from SLD.
      • You may simply disable the segment EDI_DC40 in mapping and not apply control records from payload.

      In ECC

      • Under partner type LS and PI logical system in WE20, the partner profile should exists for the mentioned message type.

      I hope it helps.

      Ambrish

  • May 03, 2013 at 03:52 PM

    Hi Bhargava,

    Looking at your mapping it looks like you are mapping 1 instance of your document (MT_Cooperative_Sender_04) to your structure ZCOOPDATA which is 1...5000.  In this particular case I would map Record -> ZCOOPDATA and also include the FCC parameter ignoreRecordsetName = true.

    Regards,

    Ryan Crosby

    Add comment
    10|10000 characters needed characters exceeded

  • May 03, 2013 at 04:07 PM

    Hi Bhargave,

    As  Ryan said add ignoreRecordsetName = true and

    check below link for more:

    http://help.sap.com/saphelp_nw04/helpdata/en/2c/181077dd7d6b4ea6a8029b20bf7e55/content.htm

    Regards,

    Gagan

    Add comment
    10|10000 characters needed characters exceeded

  • May 03, 2013 at 04:09 PM

    What's the file data that you are using? Also try adding the missingLastFields = ignore in the FCC and check.

    ~Srini

    Add comment
    10|10000 characters needed characters exceeded

  • May 03, 2013 at 05:14 PM

    HI Bhargava,

    Noticed that you have 2 levels of hierarchy Record and Row in your data type... you can just use 1. Under the data type, just have Record as 0..unbounded and it will work.

    Your error is at the adapter level and the solution above will most likely resolve it.

    Ambrish

    Add comment
    10|10000 characters needed characters exceeded