Skip to Content
avatar image
Former Member

Problem: ZMMJ starts with "In Development"

Hi all,

I have copied SMCR, SMMJ, SMHF etc. to Z-transactions, I have also make the copy rules and so on.

I have a problem with generating the ZMMJ after the ZMCR: once I put the ZMCR in development, the status of ZMMJ within the scope of the ZMCR is having the status "In Development" instead of "Created".

I have checked the status attribute, the copy rules etc., maybe I missed something but I can't find anything wrong.

Can anybody tell me where I can check?

Thanks a lot!

Kris

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • May 02, 2013 at 02:56 PM

    Hi,

    Navigate to

    Pls check the value against "After Generation" in ""Specify Status Attribute"" step.

    In my case E001 is "Created"

    Regards,

    Vivek

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 03, 2013 at 02:03 PM

    Hi Kris,

    Just to make sure, please check the status profile for ZMMJ under 'Define Status Profile for User Status' and make sure that status Created and only Created, has the Initial Status box checked:

    Kindest regards

    Paul

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 17, 2014 at 01:05 AM

    I have the exact same issue!!!!!!!!!!!!!

    I have also copied from standard and not changed a thing!!!

    ZMHF starts at "Created" but ZMMJ starts at "In Development". Configuration looks fine.

    Suggestions????????

    Add comment
    10|10000 characters needed characters exceeded

    • Ok found the issue. Looks like this is an SAP issue when you copy SMMJ to ZMMJ.

      There is an action called ZMMJ_ON_CREATE_MJ

      This is copied ok but the USER_STATUS is not set to E0001 (even though standard is). No idea why this isn't copied.

      This definitely resolves the issue.

      Cheers