Skip to Content

Installing SAP MMC on Windows PC

Hi Experts,

I have to install SAP MMC on Windows 7 system (32Bit) for Administering the SAP Systems in my landscape.

However when i add a new SAP System Instance in MMC, i cannot start/connect it.

I get the error "Cannot connect to SAP Service on <hostname>: 800706BA | The RPC Server is unavailable " with a red cross sign.

I have checked the following:

1) RPC/ Server service running on my PC

2) I have installed correctly, all the dll files are copied to Windows/System32, regsvr32 sapmmc.dll has been done successfully.

3) Also done sapstartsrv -t and "Register COM Typelibrary only"

Tried almost everything over the web, my head hurts now...

Strangely i get the vibe that a sapstartsrv_<SID>_<Inst No> service should be running (the SAP system specific SAP start Service) on my Windows 7 PC. But this service should be running on the SAP System itself (And it is running already on Linux Server).

Kindly help here.

Also I am using a older version of SAP MMC, it would be great if some one could point me to the latest stable version of SAP MMC For Windows x86 (32 Bit ) only, as i did not found any, i am using IA32 one.

Regards,

Akshay.

mmc.JPG (31.4 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Apr 26, 2013 at 11:07 AM

    Hi Akshay,

    to clarify this issue please implement following steps:

    _ if you are running realtime antivirus scanning, please deactivate for

      this try (see more details on Note 106267 Virusscanner Software under

      Windows NT)

    _ make sure you have correct version of libfrc32u.dll if your Kernel is

      unicode; - Check if librfc32.dll and librfc32u.dll are under

      %windir%\system32. If needed, refer to the Note 336693 which talks

      about how to replace the librfc32.dll.

    _ sapmmc.dll requires ADSI. Rerun the Micrsoft ADSI installation

    (ads.exe on the kernel CD in the MMC folder);

    _ then,

      once again, register the R/3 MMC Snap-in again using:

      regsvr32 sapmmc.dll (refer to SAP note 354595);

    1) Log into the NT machine as <SID>adm.

    2) Run 'sapstartsrv.exe'.

    3) Select "Uninstall Service + Unregister COM Interface"

    4) Specify your SID and System Number (NR) and click ok.

    6) Select "Install Service + Register COM Interface + Start Service

    7) Specify your SID and System Number (NR).

    8) Specify your startprofile (use the 'browse' button).

    9) Specify your user as (domain\<SID>adm) or (workgroup\<SID>adm)

    10) Specify the passsword for <SID>adm

    11) Click OK.

    Reboot the host afterwards.

    Afterwards,only if still no good,try the following :


      1. stop the SAP service

      2. open a command prompt

      3. go to usr\sap\<SID>\exe\run

      4. call 'sapstartsrv.exe -t' from the command line

      5. confirm the dialog window

      6. start the service again

    Thank You.

    Regards,

    Deepika

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Akshay Gupta

      Which SAP NetWeaver release your SAP system has? You need to use http based communicatin not DCOM. But this communication is available as of SAP NetWeaver 7.0 release only. Check settings in Security tab of Properties window.

  • avatar image
    Former Member
    Apr 27, 2013 at 07:29 AM

    Hi,

    I've the same issue implementing all the sap environment from my labs work place.

    There's a trick of sap mmc. The webservice that connent to sapservice at remote machine only undersand about hostanmes.

    1.- find the sap server hostname: simply run hostname at linux box.

    2.- if the server hostname it isn't on your DNS server add it in your hosts desktop file: C:\windows\system32\drivers\hosts

    3.- add new entry at your desktop mmc but  especify the hostname not the IP.

    And it will works.

    Cheers

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Sargan,

      Thanks for the feedback, I have already tried your suggestions earlier.

      1) My Server's hostname is not registered on DNS.

      2) I have a entry in my PC's /etc/hosts

      3) I am able to ping the server using hostname.

      4) I have added entry in SAP MMC using hostname as well.

      Still can't seem to make it work.

      Looks like there is not much to do about it now.

      Thanks though.

      Regards,

      Akshay.

      mmc2.JPG (33.4 kB)