Skip to Content
0

BOE web application errors after installing 4.2 sp3 patch 2 and 3

Jan 09, 2017 at 02:25 PM

89

avatar image

After installing 4.2 sp3 patch 2 in my development systems I got the attached errors after deploying the BOE web application. The infrastructure used is Windows 2008, Websphere7. What can I do to fix this?

bierror.png

cmcerrror.png

bierror.png (87.3 kB)
cmcerrror.png (32.5 kB)
10 |10000 characters needed characters left characters exceeded

the resolution of the attached files is soo low I can't read what they say, could you add bigger pictures ?

0

I attached bigger images.

bierrorbig.png

cmcerrorbig.png

bierrorbig.png (362.9 kB)
cmcerrorbig.png (127.2 kB)
0

that is very strange, it looks like the websphere is not able to actually run scripts but shows the source code instead.
I think you need to talk to Websphere support on this one.

0

I ran the BOE web application that was deployed with patch 1. Only once deployed from patch 2 and 3 does it produce these pages. Is there a difference between patch 1 and 2 that would cause Websphere to not run a script? A different scripting technology? It looks to me like it is missing a tag or something.

0

if you deployed pat1.ear and it works and with patch2 its not - yep, looks like something might be missing.
Open an Incident with SAP under BI-BIP-DEP component, this needs to be investigated.
I mean outside of the patches not updating warfiles directory properly, I don't see how this can happen.

0
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Tammy Powlas
Jan 09, 2017 at 02:56 PM
0

I don't know how to fix WebSphere errors, but last week there was a tweet from SAP that patch 3 for SP3 is out - why not apply that patch?

Show 1 Share
10 |10000 characters needed characters left characters exceeded

I had installed 4.2 sp3 patch 1 and the web applications were running but there were other issues that I was trying to resolve so I installed patch 2. That is when a saw the attached errors. When patch 3 came out I installed it and but it did not fix the issue with the BOE web application.

0
Ajay Gupta Jan 09, 2017 at 03:42 PM
0

David,

You want to use the WDEPLOY tool to Remove/Un-Deploy all the WAR files and do another clean WDEPLOY of all the WAR just in case.

Regards,

Ajay

Show 1 Share
10 |10000 characters needed characters left characters exceeded

After each patch update I uninstall the web application and use wdeploy to create an ear file to redeploy the applications. I did not have issues with AdminTools, dswsbobje web services application. Only the BOE application has issues.

0
Kuldeep Ghosh Jan 10, 2017 at 10:38 AM
0

did you also try to run the repair on the BO installation? Try it no harm in doing so. If there is any issues with the installation files may be repair can fix it.

Share
10 |10000 characters needed characters left characters exceeded