Skip to Content
0
Apr 22, 2013 at 06:47 PM

Error publishing endpoint

122 Views

I have a NetWeaver 7.31 server with a service registry and I'm publishing a service from an ECC 605 system. The service is active, has an endpoint and I can invoke it using the wsnavigator successfully. When I publish to the registry from soamanager I get all green lights and messages saying everything was published successfully. However, the endpoint does not show up in the registry. In the log I get these errors:

Services Registry Log Error
+-----------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| 22-Apr-13 12:56:40.380
| Method : tryRevertWSDLBindingSaving_and_ServDefinitionStateChangePerService()
| Class : com.sap.esi.uddi.sr.impl.uddi.publishers.ServicePublisher
| ThreadID : 91
+-----------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| Message : Unable to revert saving of wsdl:binidngs (uddi:tModels) and changing service definitoin state when an error occured upon publising servicewhile trying to invoke the method com.sap.esi.uddi.sr.api.types.ServiceDefinition.getConfigState() of an object loaded from an array (which itself was loaded from local variable 'sdefs') with an index loaded from local variable 'i'
+-----------------------------------------------------------------------------------------------------------------------------------------------------------------------+

followed by:

Services Registry Log Error
+-----------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| 22-Apr-13 12:56:40.382
| Method : publishService()
| Class : com.sap.esi.uddi.sr.impl.uddi.publishers.ServicePublisher
| ThreadID : 91
+-----------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| Message : com.sap.esi.uddi.sr.api.exceptions.SRPublicationException: com.sap.esi.uddi.sr.api.exceptions.SRException Error Code: 20300 Detail Message: The object referred does not existServiceDefinition not foundServiceDefinitionKey{uddiKey = null, logicalKey : String='100.SystemName.AB2.SystemNumber.0020079535.SystemHome.ab2ECC_EMPLOYEEBASICDBYEMPLOYEEQR'};
+-----------------------------------------------------------------------------------------------------------------------------------------------------------------------+
|

I assume the second error (which appears to be the reason the endpoint doesn't show up in the registry) is a result of the first. Can anyone help understand what that first error is?

Thanks,

Ross