Skip to Content
author's profile photo Former Member
Former Member

Transaction log is growing in Simple mode

Hi All,

We have installed SAP EHP6 system on MS SQL 2008 R2, Since it was development system we have kept in simple mode.

But still we find the Transaction log is growing daily and cannot truncate the log.

I found the below reuse wait reason as Replication.

Recovery model SIMPLE

Reuse wait reason REPLICATION

Do we have DB setting as above as default when we install MS SQL or any DB consultant has changed any parameter.

And also how can we remove Replication for Transaction Log.

Regards,

Kiran

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • Posted on Apr 19, 2013 at 01:29 AM

    Hi Jacinto,

    As per Note 555223 - FAQ: Microsoft SQL Server

    Q1: Is it possible to disable the transaction log completely ?

    A1: No. As the transaction log contains the 'redo' and 'undo' information for the transactions, it can't be disabled. This information is needed to ensure the logical consistency in a case of a rollback of transactions. Even when the database is in "simple" or "bulk-logged" mode, the SQL Server logs all changes in a DB into the transaction log.

    Additional information simple mode can be found int

    Note 421644 - SQL error 9002: The transaction log is full

    Section : The Simple Recovery Model

    For details on reuse wait reason/ Replication refer the link below

    http://msdn.microsoft.com/en-sg/library/ms345414(v=sql.105).aspx

    Hope this helps.

    Regards,

    Deepak Kori

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Apr 19, 2013 at 07:39 AM

    Hi,

    this link might help you to remove the replication.

    Regards

    Clas

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Apr 19, 2013 at 01:00 PM

    Good to see we have more and more people helping at the SQL Server SCN space. 😊

    Thanks @Deepak Kori and @Clas Hortien!

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 26, 2013 at 06:13 AM

    how to change Reuse_wait_reason to Nothing from LOG_BACKUP as shown in figure(below)


    combine_images.jpg (184.5 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 26, 2013 at 09:49 AM

    Hi Jacinto

    I thing your Database is enable for log shipping, may be because of that its showing the "REPLICATION"

    Regards

    Sriram

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.