Skip to Content
avatar image
Former Member

ORA-01017: invalid username/password; logon denied

Hi,

Recently I have done system copy by DB backup and restore method, I have successfully restored and recovered and the database is open but the problem is i cannot connect DB as /@<SID>, hence forth SAP cannot connect to oracle.

I have deleted and recreated ops$domain\sidadm and servicesid but no use I referred and tried

https://websmp230.sap-ag.de/sap%28bD1lbiZjPTAwMQ==%29/bc/bsp/spn/sapnotes/index2.htm?numm=400241

https://websmp230.sap-ag.de/sap%28bD1lbiZjPTAwMQ==%29/bc/bsp/spn/sapnotes/index2.htm?numm=50088 but without any luck.

OS- WIN 08 R2 distributed architecture

CI in one server and DB, DI in one server..

recent trans.log

4 ETW000 r3trans version 6.23 (release 720 - 15.01.13 - 20:13:01 ).

4 ETW000 unicode enabled version

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time   : 12.04.2013 - 12:25:58

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: r3trans -d

4 ETW000  trace at level 2 opened for a given file pointer

4 ETW000  [     dev trc,00000]  Fri Apr 12 12:25:58 2013                                                1243  0.001243

4 ETW000  [     dev trc,00000]  db_con_init called                                                        34  0.001277

4 ETW000  [     dev trc,00000]  set_use_ext_con_info(): rsdb/ssfs_connect not set => ssfs not used        43  0.001320

4 ETW000  [     dev trc,00000]  determine_block_commit: no con_hdl found as blocked for con_name = R/3

4 ETW000                                                                                                  35  0.001355

4 ETW000  [     dev trc,00000]  create_con (con_name=R/3)                                                197  0.001552

4 ETW000  [     dev trc,00000]  Loading DB library 'dboraslib.dll' ...                                    54  0.001606

4 ETW000  [     dev trc,00000]  DlLoadLib success: LoadLibrary("dboraslib.dll"), hdl 0, addr 0000000187A00000

4 ETW000                                                                                               42752  0.044358

4 ETW000  [     dev trc,00000]      using "\\CHESVLQSAP2\sapmnt\QSG\SYS\exe\uc\NTAMD64\dboraslib.dll"

4 ETW000                                                                                                  29  0.044387

4 ETW000  [     dev trc,00000]  Library 'dboraslib.dll' loaded                                            22  0.044409

4 ETW000  [     dev trc,00000]  function DbSlExpFuns loaded from library dboraslib.dll                    25  0.044434

4 ETW000  [     dev trc,00000]  Version of 'dboraslib.dll' is "720.00", patchlevel (0.417)               169  0.044603

4 ETW000  [     dev trc,00000]  function dsql_db_init loaded from library dboraslib.dll                   25  0.044628

4 ETW000  [     dev trc,00000]  function dbdd_exp_funs loaded from library dboraslib.dll                  38  0.044666

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=47=DBSL_CMD_IMP_FUNS_SET) -> changed=30, tagset=1

4 ETW000                                                                                                 218  0.044884

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=39=DBSL_CMD_SET_SINGLETASK)                     22  0.044906

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=10=DBSL_CMD_DBCA_PTR_GET)                       21  0.044927

4 ETW000  [     dev trc,00000]  New connection 0 created                                                  16  0.044943

4 ETW000  [     dev trc,00000]  0: name = R/3, con_id = -000000001, state = DISCONNECTED, tx = NO , bc = NO , hc = NO , perm = YES, reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO , prog = 

4 ETW000                                                                                                  42  0.044985

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=10=DBSL_CMD_DBCA_PTR_GET)                       26  0.045011

4 ETW000  [     dev trc,00000]  db_con_connect (con_name=R/3)                                             17  0.045028

4 ETW000  [     dev trc,00000]  determine_block_commit: no con_hdl found as blocked for con_name = R/3

4 ETW000                                                                                                  26  0.045054

4 ETW000  [     dev trc,00000]  find_con_by_name found the following connection:                          17  0.045071

4 ETW000  [     dev trc,00000]  0: name = R/3, con_id = 000000000, state = DISCONNECTED, tx = NO , bc = NO , hc = NO , perm = YES, reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO , prog = 

4 ETW000                                                                                                  38  0.045109

4 ETW000  [     dev trc,00000]  -->DbSlConnect(vers=-1, type=0, env='[default env]', usr='[default usr]', kernel dbsl='720')

4 ETW000                                                                                                 109  0.045218

4 ETW000  [     dev trc,00000]  DIR_CLIENT_ORAHOME is not set as profile nor env. parameter.             225  0.045443

4 ETW000                        Assuming using instant client with unspecified location.

4 ETW000  [     dev trc,00000]  Register application info.                                                85  0.045528

4 ETW000  [     dev trc,00000]  Oracle client version: 10.2.0.4.0, (dbsl 720 220213, UNICODE[2])       73424  0.118952

4 ETW000  [     dev trc,00000]  Detailed Oracle client (patch) info not available.                        41  0.118993

4 ETW000  [     dev trc,00000]    Default connection: tnsname ='QSG'                                      22  0.119015

4 ETW000  [     dev trc,00000]  -->oci_initialize(con=0, char='UTF16', nchar='AL16UTF16', nls=-1),uc_ln=2

4 ETW000                                                                                                  43  0.119058

4 ETW000  [     dev trc,00000]  ➖ OCIEnvCreate(mode=16384=OCI_UTF16) returned 0 (for default NLS handle)

4 ETW000                                                                                               12293  0.131351

4 ETW000  [     dev trc,00000]     OCIHandleAlloc(OCI_HTYPE_ERROR, con=0, ErrHp=02817120)                 72  0.131423

4 ETW000  [     dev trc,00000]     OCIHandleAlloc(OCI_HTYPE_ERROR, con=0, ErrBt=02818CF8)                 47  0.131470

4 ETW000  [     dev trc,00000]  NLS env. settings: lang=41004D00450052004900430041004E00                 750  0.132220

4 ETW000  [     dev trc,00000]                     terr=41004D0045005200490043004100                      35  0.132255

4 ETW000  [     dev trc,00000]                     char=55005400460031003600                              22  0.132277

4 ETW000  [     dev trc,00000]  Client NLS setting (by OCINlsGetInfo(con=0)): 'AMERICAN_AMERICA.UTF16'

4 ETW000                                                                                                  30  0.132307

4 ETW000  [     dev trc,00000]  charset='UTF16', ncharset='AL16UTF16', UNI_ASC=FALSE                      20  0.132327

4 ETW000  [     dev trc,00000]  Logon as OPS$-user to get SAPPSG's password                               30  0.132357

4 ETW000  [     dev trc,00000]  Connecting as /@QSG on connection 0 (nls 0) ... (dbsl 720 220213, UNICODE[2])

4 ETW000                                                                                                  35  0.132392

4 ETW000  [     dev trc,00000]     OCIHandleAlloc(OCI_HTYPE_SVCCTX, con=0, svchp=02818BB8)               251  0.132643

4 ETW000  [     dev trc,00000]  Allocating server context handle                                          31  0.132674

4 ETW000  [     dev trc,00000]  Attaching to database server QSG (con=0, svchp=02818BB8, srvhp=0281D428)

4 ETW000                                                                                                  62  0.132736

4 ETW000  [     dev trc,00000]  Assigning server context 0281D428 to service context 02818BB8          46921  0.179657

4 ETW000  [     dev trc,00000]     OCIHandleAlloc(OCI_HTYPE_SESSION, con=0, usrhp=0282A010)             2828  0.182485

4 ETW000  [     dev trc,00000]  Starting user session: OCISessionBegin(con=0, usr='/', svc=02818BB8, srv=0281D428, usr=0282A010)

4 ETW000                                                                                                  50  0.182535

4 ETW000  [     dev trc,00000]     OCISessionBegin(OCI_DEFAULT) failed with -1=OCI_ERROR               31846  0.214381

4 ETW000  [     dev trc,00000]     OCISessionBegin(OCI_DEFAULT) failed with SQL error 1017:               97  0.214478

4 ETW000  [     dev trc,00000]     ORA-01017: invalid username/password; logon denied                                                                           

4 ETW000                                                                                                  40  0.214518

4 ETW000  [    dbsloci.,00000]  *** ERROR => CONNECT failed with sql error '1017'                        421  0.214939

4 ETW000  [     dev trc,00000]     set_ocica() -> SQL error code 1017                                     37  0.214976

4 ETW000  [     dev trc,00000]  -->oci_get_errmsg (con=0, rc=1017)                                        21  0.214997

4 ETW000  [     dev trc,00000]     OCIErrorGet -> SQL error code: 1017                                    64  0.215061

4 ETW000  [     dev trc,00000]     ORA-01017: invalid username/password; logon denied                                                                           

4 ETW000                                                                                                  37  0.215098

4 ETW000  [     dev trc,00000]  Info: 99=DBSL_ERR_DB, oerr=1017, try to connect with default password.

4 ETW000                                                                                                  38  0.215136

4 ETW000  [     dev trc,00000]  Connecting as SAPPSG/<pwd>@QSG on connection 0 (nls 0) ... (dbsl 720 220213, UNICODE[2])

4 ETW000                                                                                                  33  0.215169

4 ETW000  [     dev trc,00000]  Assigning username to user session: con=0, usrhp=0282A010                 26  0.215195

4 ETW000  [     dev trc,00000]  Assigning password to user session: con=0, usrhp=0282A010                 35  0.215230

4 ETW000  [     dev trc,00000]  Starting user session: OCISessionBegin(con=0, usr='SAPPSG', svc=02818BB8, srv=0281D428, usr=0282A010)

4 ETW000                                                                                                1918  0.217148

4 ETW000  [     dev trc,00000]     OCISessionBegin(OCI_DEFAULT) failed with -1=OCI_ERROR                3438  0.220586

4 ETW000  [     dev trc,00000]     OCISessionBegin(OCI_DEFAULT) failed with SQL error 1017:               81  0.220667

4 ETW000  [     dev trc,00000]     ORA-01017: invalid username/password; logon denied                                                                           

4 ETW000                                                                                                  39  0.220706

4 ETW000  [    dbsloci.,00000]  *** ERROR => CONNECT failed with sql error '1017'                         39  0.220745

4 ETW000  [     dev trc,00000]     set_ocica() -> SQL error code 1017                                     21  0.220766

4 ETW000  [     dev trc,00000]  -->oci_get_errmsg (con=0, rc=1017)                                        19  0.220785

4 ETW000  [     dev trc,00000]     OCIErrorGet -> SQL error code: 1017                                    58  0.220843

4 ETW000  [     dev trc,00000]     ORA-01017: invalid username/password; logon denied                                                                           

4 ETW000                                                                                                  37  0.220880

4 ETW000  [     dev trc,00000]     DbSlConnect(con=0) -> orc=0, 99=DBSL_ERR_DB                            24  0.220904

4 ETW000  [    dblink  ,00000]  ***LOG BY2=>sql error 1017   performing CON                              251  0.221155

4 ETW000  [    dblink  ,00000]  ***LOG BY0=>ORA-01017: invalid username/password; logon denied            31  0.221186

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=41=DBSL_CMD_RELINFO_GET)                       246  0.221432

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=14=DBSL_CMD_VERSION_GET)                        40  0.221472

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=50=DBSL_CMD_GET_PATCH_INFO)                     22  0.221494

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=13=DBSL_CMD_VENDOR_NAME_GET)                    60  0.221554

4 ETW000  [     dev trc,00000]  -->DbSlControl(con=-1,cmd=52=DBSL_CMD_GET_DBLIB_VERSION)                  23  0.221577

4 ETW000  [     dev trc,00000]                 -> 'OCI_10201_SHARE, 10.2.0.4.0'                           21  0.221598

2EETW169 no connect possible: "DBMS = ORACLE                           --- dbs_ora_tnsname = 'QSG'"

Awaiting for any suggestion

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Apr 18, 2013 at 09:56 PM

    Hi Harsha,

    ORA-01017 means that the username and password specified for the
    SAPDB user in configtool does not match the password for the Oracle
    Database

    Please check the SecStore' in Configtool and ensure you have the correct
    username and password specified to connect to the Database
    See SAP  note 400241 for details on this error.

    Anyway I just see you have fixed this.

    Regards,

    David

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi David,

      First of all we have only ABAP stack.

      The error was because of ops$user, we have basically CI in one server and DI and DB instance on other server, but whenever CI or DI tried reaching DB

      I use to get this error in dev_w0 as well as in trans.log .

      So I deleted the old ops$ users and recreated as per in the NOTE-50088, but the only correction I did was I created induvidual ops$ users as per their hostname isntead of common domain.

      Then reset the SAPSID user password thru BRconnect, so that it will get updated in SAPUSER table.

      Finally I changed dbs_ora_schema to source SAPSID (SID-target SID) env variable, by this changes issue got resolved.

      BR,

      Harsha

  • avatar image
    Former Member
    Apr 16, 2013 at 08:50 AM

    Solved by myself..

    Problem with ops$user

    Add comment
    10|10000 characters needed characters exceeded