Skip to Content

Afaria enrollment problem with iOS

Hello,

I have installed Afaria 7.0 with the Afaria Appliance virtual machine image.

I've configured Afaria with the Appliance wizard (AfariaApplianceSetup.exe).


Then I've upgraded Afaria components to SP3:

-     Afaria Server

-     Afaria Administrator

-     Enrollment Server

-     Package Server

-     Self-Service Portal


I've generated and installed cerificates for iOS MDM.

Afaria server is configured also as CA server.


Afaria seems to work correctly but I'm not able to enroll an iOS device (Ipad): I've tried using Self-Service Portal, the portal gives me the enrollment code correctly, I authenticate to Afaria Server using afariaadmin user (local administrator on the afaria server).

I receive the Profile Service (Sybase - iAnywhere) not signed so if I try to intall it I have this error: una transazione con il server a  "http://<afria server IP>/aips/aipService.svc/PostData" non è riuscita e ha causato lo stato "401".


In Afaria Administrator I can see the device registered but I think it is not under MDM control.


Any ideas?


Thanks in advance


Piero

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Apr 16, 2013 at 07:36 PM

    During the Enrollment Server setup, did you select the option to "Use Authentication"?

    You can check this by navigating to the aips virtual directory in IIS Manager and view the Authetnication option you may have enabled for the site. An easy thing to test is to enable only "Anonymous" authentication on the aips website and see if enrollment is now successful.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      It would be great if someone explains about the authentication in detail.

      in my case in I have set up the authentication for IIS virtual directories as depicted below,

      Afaria>> Windows authentication enabled

      aips>> Anonymous authentication enabled

      aips2>>Anonymous authentication enabled

      aipsr>>Forms & Windows authentication enabled.

      I am facing an issue the authentication screen is appearing again and again as non-stop,

      could suggest how can I avoid that what authentication I would require If I want to have windows authentication alone. eg when I open afaria custom client I expect the prompt to appear once to ask to enter the windows credentials and then log into afaria custom client.

      Regards,

      Saravanan.R