Skip to Content
1
Former Member
Apr 04, 2013 at 08:10 AM

error:2EETW169 no connect possible: "DBMS = ORACLE--- dbs_ora_tnsname

1048 Views

Hello All,


We have ECC 6.0 IDES System in Oracle 11g as Database we have unix as Operating System.


We can not start SAP after restart DB.


sapux24:risadm 35> R3trans -d
This is R3trans version 6.14 (release 700 - 24.07.12 - 20:12:04 ).
unicode enabled version
2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'RIS'"
R3trans finished (0012).


Oracle database is Up, Listener is Up , SAPOSCOL is running


We have change SAPR3 user password with BRTOOLS,
but still the same problem


I think there is problem with Authentication as it is seen in the log file.

Her is trans.log file

4 ETW000 R3trans version 6.14 (release 700 - 24.07.12 - 20:12:04 ).
4 ETW000 unicode enabled version
4 ETW000 ===============================================
4 ETW000
4 ETW000 date&time : 04.04.2013 - 09:01:44
4 ETW000 control file: <no ctrlfile>
4 ETW000 R3trans was called as follows: R3trans -d
4 ETW000 trace at level 2 opened for a given file pointer
4 ETW000 [ dev trc,00000] Thu Apr 4 09:01:44 2013 427 0.000427
4 ETW000 [ dev trc,00000] db_con_init called 16 0.000443
4 ETW000 [ dev trc,00000] create_con (con_name=R/3) 75 0.000518
4 ETW000 [ dev trc,00000] Loading DB library '/usr/sap/RIS/SYS/exe/run/dboraslib.so' ... 29 0.000547
4 ETW000 [ dev trc,00000] DlLoadLib() success: dlopen("/usr/sap/RIS/SYS/exe/run/dboraslib.so"), hdl 0
4 ETW000 34053 0.034600
4 ETW000 [ dev trc,00000] Library '/usr/sap/RIS/SYS/exe/run/dboraslib.so' loaded 29 0.034629
4 ETW000 [ dev trc,00000] function DbSlExpFuns loaded from library /usr/sap/RIS/SYS/exe/run/dboraslib.so
4 ETW000 40 0.034669
4 ETW000 [ dev trc,00000] Version of '/usr/sap/RIS/SYS/exe/run/dboraslib.so' is "700.08", patchlevel (0.342)
4 ETW000 345 0.035014
4 ETW000 [ dev trc,00000] function dsql_db_init loaded from library /usr/sap/RIS/SYS/exe/run/dboraslib.so
4 ETW000 30 0.035044
4 ETW000 [ dev trc,00000] function dbdd_exp_funs loaded from library /usr/sap/RIS/SYS/exe/run/dboraslib.so
4 ETW000 76 0.035120
4 ETW000 [ dev trc,00000] New connection 0 created 58 0.035178
4 ETW000 [ dev trc,00000] 000: name = R/3, con_id = -000000001, state = DISCONNECTED, tx = NO , hc = NO , perm = YES,
4 ETW000 reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO
4 ETW000 182 0.035360
4 ETW000 [ dev trc,00000] db_con_connect (con_name=R/3) 39 0.035399
4 ETW000 [ dev trc,00000] find_con_by_name found the following connection for reuse: 14 0.035413
4 ETW000 [ dev trc,00000] 000: name = R/3, con_id = 000000000, state = DISCONNECTED, tx = NO , hc = NO , perm = YES,
4 ETW000 reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO
4 ETW000 37 0.035450
4 ETW000 [ dev trc,00000] -->oci_init1 322 0.035772
4 ETW000 [ dev trc,00000] Oracle Client Version: '11.2.0.3.0', (dbsl 700 110412, UNICODE[2]) 163 0.035935
4 ETW000 [ dev trc,00000] Default connection: tnsname ='RIS' 17 0.035952
4 ETW000 [ dev trc,00000] -->oci_initialize(con=0, char='UTF16', nchar='AL16UTF16', uc_ln=2) 30 0.035982
4 ETW000 [ dev trc,00000] Application info callback registered. 16 0.035998
4 ETW000 [ dev trc,00000] ➖ OCIEnvCreate(mode=16384=OCI_UTF16) returned 0 (for default NLS handle)
4 ETW000 13699 0.049697
4 ETW000 [ dev trc,00000] OCIHandleAlloc(OCI_HTYPE_ERROR, con=0, ErrHp=0x6000000001139588) 109 0.049806
4 ETW000 [ dev trc,00000] OCIHandleAlloc(OCI_HTYPE_ERROR, con=0, ErrBt=0x600000000113a628) 41 0.049847
4 ETW000 [ dev trc,00000] NLS env.: lang=0041004D00450052004900430041004E 337 0.050184
4 ETW000 [ dev trc,00000] terr=0041004D00450052004900430041 22 0.050206
4 ETW000 [ dev trc,00000] char=00550054004600310036 18 0.050224
4 ETW000 [ dev trc,00000] Client NLS setting (by OCINlsGetInfo): con=0, 'AMERICAN_AMERICA.UTF16'
4 ETW000 23 0.050247
4 ETW000 [ dev trc,00000] charset='UTF16', ncharset='AL16UTF16', UNI_ASC=FALSE 15 0.050262
4 ETW000 [ dev trc,00000] Logon as OPS$-user to get SAPR3's password 45 0.050307
4 ETW000 [ dev trc,00000] Connecting as /@RIS on connection 0 (nls 0) ... (dbsl 700 110412, UNICODE[2])
4 ETW000 26 0.050333
4 ETW000 [ dev trc,00000] Allocating service context handle for con=0 48 0.050381
4 ETW000 [ dev trc,00000] Allocating server context handle 19 0.050400
4 ETW000 [ dev trc,00000] Attaching to DB Server RIS (con=0,svchp=0x600000000113a548,srvhp=0x600000000113d6b0)
4 ETW000 167 0.050567
4 ETW000 [ dev trc,00000] Assigning server context 0x600000000113d6b0 to service context 0x600000000113a548
4 ETW000 94781 0.145348
4 ETW000 [ dev trc,00000] Allocating user session handle 120 0.145468
4 ETW000 [ dev trc,00000] Starting user session: OCISessionBegin(con=0, usr='/',svchp=0x600000000113a548, srvhp=0x600000000113d6b0, usrhp=0x60000000011c1be0)
4 ETW000 56 0.145524
4 ETW000 [ dev trc,00000] OCISessionBegin(OCI_DEFAULT) failed with -1=OCI_ERROR 8781 0.154305
4 ETW000 [ dev trc,00000] OCISessionBegin(OCI_DEFAULT) failed with SQL error 1017: 446 0.154751
4 ETW000 [ dev trc,00000] ORA-01017: invalid username/password; logon denied
4 ETW000 36 0.154787
4 ETW000 [ dbsloci.,00000] *** ERROR => CONNECT failed with sql error '1017' 60 0.154847
4 ETW000 [ dev trc,00000] set_ocica() -> SQL error code 1017 16 0.154863
4 ETW000 [ dev trc,00000] -->oci_get_errmsg (con=0, rc=1017) 16 0.154879
4 ETW000 [ dev trc,00000] OCIErrorGet -> SQL error code: 1017 87 0.154966
4 ETW000 [ dev trc,00000] ORA-01017: invalid username/password; logon denied
4 ETW000 27 0.154993
4 ETW000 [ dev trc,00000] Info: 99=DBSL_ERR_DB, oerr=1017, try to connect with default password.
4 ETW000 49 0.155042
4 ETW000 [ dev trc,00000] Connecting as SAPR3/<pwd>@RIS on connection 0 (nls 0) ... (dbsl 700 110412, UNICODE[2])
4 ETW000 28 0.155070
4 ETW000 [ dev trc,00000] Assigning username to user session: con=0, usrhp=0x60000000011c1be0 18 0.155088
4 ETW000 [ dev trc,00000] Assigning password to user session: con=0, usrhp=0x60000000011c1be0 143 0.155231
4 ETW000 [ dev trc,00000] Starting user session: OCISessionBegin(con=0, usr=SAPR3/<pwd>, svchp=0x600000000113a548, srvhp=0x600000000113d6b0, usrhp=0x60000000011c1be0)
4 ETW000 641 0.155872
4 ETW000 [ dev trc,00000] Thu Apr 4 09:01:50 2013 6011089 6.166961
4 ETW000 [ dev trc,00000] OCISessionBegin(OCI_DEFAULT) failed with -1=OCI_ERROR 37 6.166998
4 ETW000 [ dev trc,00000] OCISessionBegin(OCI_DEFAULT) failed with SQL error 1017: 131 6.167129
4 ETW000 [ dev trc,00000] ORA-01017: invalid username/password; logon denied
4 ETW000 31 6.167160
4 ETW000 [ dbsloci.,00000] *** ERROR => CONNECT failed with sql error '1017' 24 6.167184
4 ETW000 [ dev trc,00000] set_ocica() -> SQL error code 1017 16 6.167200
4 ETW000 [ dev trc,00000] -->oci_get_errmsg (con=0, rc=1017) 16 6.167216
4 ETW000 [ dev trc,00000] OCIErrorGet -> SQL error code: 1017 86 6.167302
4 ETW000 [ dev trc,00000] ORA-01017: invalid username/password; logon denied
4 ETW000 27 6.167329
4 ETW000 [ dblink ,00433] ***LOG BY2=>sql error 1017 performing CON [dblink#8 @ 433] 237 6.167566
4 ETW000 [ dblink ,00433] ***LOG BY0=>ORA-01017: invalid username/password; logon denied [dblink#8 @ 433]
4 ETW000 28 6.167594
2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'RIS'"

Thanks for any help.

R3trans -d giving error:2EETW169 no connect possible: "DBMS = ORACLE--- dbs_ora_tnsname = 'DEV'"