Skip to Content
0
Former Member
Apr 02, 2013 at 02:08 AM

Connect to HANA with unixODBC fails

1735 Views

Dear community

I like to connect with PHP to the HANA server, using all information from the treads (http://scn.sap.com/message/13382450#13382450 http://scn.sap.com/thread/2134802 http://scn.sap.com/thread/3204662 )

I tried the following on the HANA box (SLES 10 SP2) itself and from a linux client (openSuse 12.2)

Using unixODBC with isql i get always the following error messages

isql DSN SYSTEM secret -v

openSuse 32Bit: (downloaded from here)

[08S01][unixODBC][SAP AG][LIBODBCHDB32 SO][HDB] Communication link failure;-10709 Connect failed (no reachable host left)

SLES 10SP2 64Bit (download from here)

[08S01][unixODBC][SAP AG][LIBODBCHDB SO][HDB] Communication link failure;-10709 Connect failed (no reachable host left)

The error comes imediatly which gives me the impression, that the ServerNode parameter is not interpreted at all

openSuse 32Bit:

/etc/unixODBC/odbc.ini:

[HANADSN]

Driver=/usr/sap/hanaclient32/libodbcHDB32.so

ServerNode=hanab1:30015

SLES 10SP2 64Bit

/etc/unixODBC/odbc.ini:

[HANADSN]

Driver=/usr/sap/hanaclient/libodbcHDB.so

ServerNode=hanab1:30015

I tried with unixODBC 2.12 and also 2.3. On the HANA host it self I tried with localhost, 127.0.0.1 and the IP address

On the openSUSE Client I tried servername and ip-address.

To use /usr/sap/hdbclient32/odbcreg32 (or /usr/sap/hdbclient/odbcreg) I got first an error message, that the libodbcHDB... was not found.

LD_LIBRARY_PATH=/usr/sap/hdbclient32/ and export LD_LIBRARY_PATH solved that problem

using odbcreg SERVER:PORT NDB SYSTEM sercret works. Connects to HANA and shows now()

Using odbcreg DSN SYSTEM secret does not work, shows the same error as above immediately (not timeout waiting for the connection).

I assume, that the parameter ServerNode= is not interpreted. I have tried Host= / Port= and Server=, but always the same result.

It would be helpfull, when SAP publishes an odbctemplate, that tools like ODBCconfig (X-Windows tool to configure the odbc.ini file) can work.

Thanks

Ingo