Skip to Content
author's profile photo Former Member
Former Member

disp+work.exe running but Message Server Unreachable

Hi all,

I am new bee to this forum. can anybody guide me about this problem. i was working around for the past 4 days. still i was not able to find out the solution for this problem. when i am trying to connect SAP Server through SAPGUI, it was not connecting. i cross check with SAP MMC in the process list only one process was running (Message service) remaing processes were stopped. but disp+work.exe was running but with error message as <b>"Running but message server unreachable"</b>. as per my knowledge this may be problem with sapmsg.ini. plz let me know how to fix this problem.

Add a comment
10|10000 characters needed characters exceeded

Related questions

7 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Aug 22, 2005 at 12:07 PM

    Hi Ramesh,

    Please apply the latest Kernel Path to the System.

    regards

    Anand.M

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 23, 2005 at 11:22 PM

    your c:\windows\system32\drivers\etc\services file might have changed. Check that whether you have an entry in the services file for that sysid and port.

    regards

    SKM

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 29, 2005 at 05:56 AM

    Hi all,

    I have the same problem, and I have checked all the ports in C:\WINNT\system32\drivers\etc\services which are all existence.

    Description:

    After my installing IDES server, i want to prevent multi-user login this system, so I use the Transcaction RZ10 to change Default.pfl with adding a parameter "login/disable_multi_gui_login = 1", than I close databse and restart the system. But when i want to use SAPMMC to set up SAP instance, disp+work.exe dosen't work just as "Running but not connected to Message Server". When i try to logon SAP GUI, error message is like this "no logon possible(no hw ID received by mssg server)" after my imput my user name and password.

    What I do is just to have chaged profile "default.pfl" with adding a parameter "login/disable_multi_gui_login = 1", I don't know why?

    Anybody can help me?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello to all of you,

      please inform me with:

      -your R/3 release

      -your kernel level (find in SM51->release information)

      -please restart your system (via mmc) and check your trace file:

      usr\sap\<SID>\DVEBMGSXX\work\dev_disp

      usr\sap\<SID>\DVEBMGSXX\work\ms

      (send it sallaboy@gmail.com or publish here)

      Regards,

      Dimitry

  • author's profile photo Former Member
    Former Member
    Posted on Sep 29, 2005 at 07:49 AM

    Dimitry Haritonov

    Thanks for your help.

    My R/3 sysetem: 4.7

    Kernel level : I think it shoud be 640_REL, for I could not login my SAP system ever.

    dev_disp:

    ERROR => MsISnd2: not_attached [msxxi.c 1180]

    LOG Q0N=> DpRqNoWpHandle, MsSndName () [dpxxdisp.c 3873]

    ms: I could not find this file at usr\sap\....\work\...

    Additionally, the sapstart.log is

    "SAP-R/3-Startup Program

    Starting at 2005/09/29 15:23:39

    Startup Profile: "D:\usr\sap\PSE\SYS\profile\START_DVEBMGS00_idesserver"

    Starting Programs

    (2452) Execute: D:\usr\sap\PSE\SYS\exe\run\strdbs.cmd PSE

    (2488) CreateProcess: D:\usr\sap\PSE\SYS\exe\run\msg_server.exe pf=D:\usr\sap\PSE\SYS\profile\PSE_DVEBMGS00_idesserver

    (2496) CreateProcess: D:\usr\sap\PSE\SYS\exe\run\disp+work.exe pf=D:\usr\sap\PSE\SYS\profile\PSE_DVEBMGS00_idesserver

    (2504) CreateProcess: D:\usr\sap\PSE\DVEBMGS00\igs\bin\igswd.exe -dir=D:\usr\sap\PSE\DVEBMGS00\igs -mode=all

    "

    All the above is enough?

    Thanks.

    Best regard,

    Paul

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      hello dimitry.

      I'd installed SAP R/3 4.6Csr2 on Wserver 2003 with oracle 9.0.2 and I can't loggin with the user DDIC message : no hw ID received by mssg server.

      But I can loggin with the user SAP*...

      Do you have an idea ?

      Regards.

  • author's profile photo Former Member
    Former Member
    Posted on Sep 30, 2005 at 06:37 AM

    Dear Dimitry,

    The zip file is too big to transfer to you.

    So i can't do this.

    Now, I have resolved this problem by reinstalling SAP instance.

    Thanks very much anywhere.

    You are so warmhearted.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 04, 2007 at 02:22 PM

    Hi Ramesh,

    Can you post the dev_msg file in your 'work' directory.

    Regards,

    Siddhesh

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 12, 2012 at 12:22 PM

    Hi!

    I have same problem after installation SAPNW7. TrialSP12.

    I'm running virtual MS Windows SP2 using VMWare Workstation 8.0

    dev_ms is attached.

    ---------------------------------------------------

    trc file: "dev_ms", trc level: 1, release: "700"

    ---------------------------------------------------

    [Thr 3436] Sat May 12 11:17:33 2012

    [Thr 3436] MsSSetTrcLog: trc logging active, max size = 20971520 bytes

    systemid 560 (PC with Windows NT)

    relno 7000

    patchlevel 0

    patchno 94

    intno 20050900

    make: multithreaded, ASCII, optimized

    pid 3432

    [Thr 3436] ***LOG Q01=> MsSInit, MSStart (Msg Server 1 3432) [msxxserv.c 1824]

    [Thr 3436] MsInitAclInfo: acl file D:\NSP\SYS\global\ms_acl_info.DAT not found, unrestricted access

    [Thr 3436] MsGetOwnIpAddr: my host addresses are :

    [Thr 3436] 1 : [10.10.0.10] sap.localhost (HOSTNAME)

    [Thr 3436] 2 : [127.0.0.1] localhost (LOCALHOST)

    [Thr 3436] 3 : [192.168.238.128] allon-51c22207c.corp.loc (NILIST)

    [Thr 3436] MsHttpInit: full qualified hostname = sap.localhost

    [Thr 3436] HTTP logging is switch off

    [Thr 3436] set HTTP state to LISTEN

    [Thr 3436] MsHttpOwnDomain: own domain[1] = localhost

    [Thr 3436] ms/icf_info_server : deleted

    [Thr 3436] *** I listen to port sapmsNSP (3600) ***

    [Thr 3436] *** I listen to internal port 3900 (3900) ***

    [Thr 3436] *** HTTP port 8100 state LISTEN ***

    [Thr 3436] CUSTOMER KEY: >I1895797210<

    [Thr 3436] Sat May 12 11:28:22 2012

    [Thr 3436] *** ERROR => MsSCheckConnections: no response from client C0 (10.10.0.10) after 300 secs received [msxxserv.c 3165]

    [Thr 3436] *** ERROR => MsSCheckConnections: disconnect now [10.10.0.10] [msxxserv.c 3169]

    Regards,

    Olga.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Olga,

      Can you clarify the IP address and hostname of the virtual Windows where the instance is installed?

      Following 2 lines shows 2 IP which I am confuse what are they for. Maybe the answer is there

      [Thr 3436] 1 : [10.10.0.10] sap.localhost (HOSTNAME)

      [Thr 3436] 3 : [192.168.238.128] allon-51c22207c.corp.loc (NILIST)

      I recommend to set a proper IP (default VMware IP is good) and hostname (or Windows computer name) to the virtual Windows. SAP and many other applications need valid value in order to install, especially troubleshooting

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.