Skip to Content
avatar image
Former Member

All columns are not appearing in one row in the SPOOL generated for background job for ABAP Report

Hi Experts,

I have creted one ABAP report for FI .It has total 90 columns.When i am scheduling it in background the spool is generated.But all columns are not appearing in one row.Some of the columns are being appended to the first row. I have checked this issue on forum but nothing works for me.I have used REUSE_ALV_LIST_DISPLAY when scheduling in background

IF sy-batch EQ 'X'.

CALL FUNCTION 'REUSE_ALV_EVENTS_GET'
EXPORTING
i_list_type = 0
IMPORTING
et_events = it_events[].

READ TABLE it_events WITH KEY name = 'TOP_OF_PAGE'
INTO wa_events.
MOVE 'TOP_OF_PAGE' TO wa_events-form.
APPEND wa_events TO it_events.

CALL FUNCTION 'REUSE_ALV_LIST_DISPLAY'
EXPORTING
* I_INTERFACE_CHECK = ' '
* I_BYPASSING_BUFFER =
* I_BUFFER_ACTIVE = ' '
i_callback_program = sy-repid
* I_CALLBACK_PF_STATUS_SET = ' '
* I_CALLBACK_USER_COMMAND = ' '
* I_STRUCTURE_NAME =
is_layout = it_layout
it_fieldcat = it_fcatalog
* IT_EXCLUDING =
* IT_SPECIAL_GROUPS =
* IT_SORT =
* IT_FILTER =
* IS_SEL_HIDE =
I_DEFAULT = 'X'
* I_SAVE = ' '
* IS_VARIANT =
it_events = it_events
* IT_EVENT_EXIT =
* IS_PRINT =
* IS_REPREP_ID =
* I_SCREEN_START_COLUMN = 0
* I_SCREEN_START_LINE = 0
* I_SCREEN_END_COLUMN = 0
* I_SCREEN_END_LINE = 0
* IR_SALV_LIST_ADAPTER =
* IT_EXCEPT_QINFO =
* I_SUPPRESS_EMPTY_DATA = ABAP_FALSE
TABLES
t_outtab = itab1
EXCEPTIONS
program_error = 1
OTHERS = 2.
IF sy-subrc <> 0.
* Implement suitable error handling here
ENDIF.

Even i have checked the SPAD Config which has already maximum columns 1023 and even the check box is also checked for No of colums for list display from format


Could anyone please help me on this?


Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

0 Answers