Skip to Content
author's profile photo Former Member
Former Member

Data available in target but not available in the report.

Hi All

I am a beginner in SAP BI. Could you please help me solve the below issue.

Few territories(characteristic) are missing in the report Stock tracking. But I am able to see those territories in the Multiprovider from which the report is generated.

I have checked the characteristic restrictions in the query.

  1. 1. The info provider is restricted to pull data only from one cube
  2. 2. Business unit is restricted based on authorizations.

The initial selection for the report includes

  1. 1. Current version - calculated from the forecast version field of the multiprovider(by default it takes the forecast version of the last load)
  2. 2. Reference version - Manual input
  3. 3. Material group - Manual input.

I have filtered the data as per the above condition in the multiprovider and I am able to see the data for all the territory. But in the report few territories are missing for the same forecast version.

Kindly let me know for any further details.

Thanks

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Mar 17, 2013 at 02:05 PM

    Usha,

    Check in Listcube whether you are able to see the data for the same restriction(if any in query).

    Also check in request , whether you are able to see query symbol, if that sign is nor you wont see data

    in query.

    Regards,

    Venkatesh

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi ,

      I could see data in ListCube also the data were available till last week but this morning when i opened workbook it was not available.

      later when i again saved my report data was available .

      Please explain any technical issue.

  • author's profile photo Former Member
    Former Member
    Posted on Mar 18, 2013 at 12:04 PM

    Hi,

    Check the things which you have restricted in your query as you said data is available in infoprovider but some data not populated in reports,

    1..check data in that particular cube which you have restricted to pull data.

    2.with same restrictions as you have applied in your scenario..

    regards

    Atul

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 28, 2013 at 06:31 AM

    first ensure the required data in Multiprovider.if required data is available in multiprovider but not populated in your report that means there is no issue in modeling part , then you have to check that query which you have designed on that multiprovider.

    In query designer remove all restictions ,drag required characterstics and keyfigures and then check the data through RSRT or Query analyser.

    regards

    Atul

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 28, 2013 at 07:29 AM

    Hi Usha,

    Have you checked for the data in the MP for that particular iC which is restricted in report level? Are you able to see data for this in MP?

    How did you confirmed data is missing in report?

    Do one thing copy the existing query and try to remove the restrictions one bye one and replacing one by one and check the output how the queyr is behaving so that you can get idea where its getting filtered and why its not getting displayed in the report.

    Also Check if you have authorization for Business units.

    Regards

    KP

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 27, 2013 at 04:50 AM

    Sorry for the delay.

    The Data was not available because of a condition for tolerance value in the report which will fetch only positive values. Hence the end markets which have negative values are not shown.

    Thanks everyone.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.