Skip to Content
0
Mar 14, 2013 at 05:20 PM

turn delta merge off

1330 Views

I have a stored procedure doing joins and transformation in a loop and writing to a column table in HANA.

The stored Procedure is taking 65 minutes to run in Prod for a 50 million with 40 million left join .

Seems that during the entire run , not a single record is written . but at the end of 65 min all the records are written all at once . Seems that "MERGE delta " is running all during this time .

How do I disable DELTA MERGE , so that the stored procedure bypasses it and writes to the physical table directly .

Would table lock be an option ?