Skip to Content

Output for Print

Hi,

Requirement

Business wants to see a copy of PDF Invoice when the Billing document gets created in SAP only and do not want the Invoice to be printed physically through a printer.

Configuration.

A separate output type was created Z*** and configured accordingly.

Condition records was also created with the following details.

Medium set as  - "1" i.e. Print Output.

Date/Time set as - "4" i.e. Send immediately (when saving the application).

The "Print Immediately" check button in the Communication section (there is a communication button in the application toolbar) is NOT set to avoid immediate printing.

Issue

Even though the Output type has been configured not to print the Invoices, physical copies of Invoices are getting printed.


************************************************************

Please let me know if anything has been incorrectly configured. How do I configure the system to meet the requirement.

Thanks,

Himanshu.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Mar 12, 2013 at 07:52 AM

    Himanshu

    Probably, you have a printer details in communication method for following:

    Medium set as  - "1" i.e. Print Output.

    Date/Time set as - "4" i.e. Send immediately (when saving the application).

    For your Z Output type's condition record, in communication method, you need to maintain Logical destination or printer name as LP01 or LOCAL or have configured printer device w/o physical destination.

    Thanks, JP

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks JP. 😊

      The Local printer has been configured and it is the default, however we do not want the spool to be created so that it is not processed and the invoices get printed.

      I have changed the storage mode in the output condition record from "Print and Archive" to only "Archive" and it seems to work fine.

      The spool creation has stopped and hence it is not getting printed anymore. However we are monitoring this very closely and waiting for an update from Business.

      If this problem still persists, I will update this discussion with more details.

      Thanks,

      Himanshu.

  • avatar image
    Former Member
    Mar 12, 2013 at 11:48 AM

    Hi,

    As per your setting you have already putted

    Date/Time set as - "4" i.e. Send immediately (when saving the application).

    So according to that it will print immediately if the printer is installed on SAP. 

    If you are using any local printer which is not installed on SAP in that case the communication tab "Print immediately " tick mark will work . for which  output device you will put in the left side  i.e "Output Device" field.

    So it ll work only for you local printer which is  installed only you printer.

    so remove the condition record Date/Time "4 " if you printer is installed in SAP >

    Hope it ll help you

    Regards

    Pitabash

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks Pitabash for your time to answer my queries. 😊

      Please check my response to JP's comments above. It seems to have worked for the time being, however we are still monitoring it and waiting for Business's response.

      Thanks,

      Himanshu.