Skip to Content
avatar image
Former Member

user DDIC is not authorized to start TP sapxpg on host

Hello Friends,

I have a distributed system SAP ECC6, on linux 64 bit as OS on one host(svlixxca1) with oracle 11.2.0.3.0 on another host(svlixxca2). I tried to schedule DB13 DB clean up job once in a week after a fresh installation, first I tried with a user who has SAP_ALL, and SAP_NEW authorization in 000, it got failed last weekend, then I tried with DDIC, again it got failed this weekend.

SM37 job log says:

SXPG_COMMAND_EXECUTE failed for BRCONNECT - Reason: program_start_error: For More Information, See SYS. Job cancelled after system exception ERROR_MESSAGE.

Developer trace displays below error:

**** Trace file opened at 20130310 030012 CET, by disp+work

**** Versions SAP-REL 720,0,401 RFC-VER U 3 1386868 MT-SL

======> CPIC-CALL: 'ThSAPOCMINIT' : cmRc=20 thRc=20

No storage allocation available

ABAP Programm: SAPLCRFC (Transaction: )

User: DDIC (Client: 000)

Destination: %_TCPIP_%1 (Handle: 1, DtConId: 513BC20B957E5597E10000000A6BA2FE, DtConCnt: 0, ConvId: ,)

EPP RootContextId: 005056B9592B1ED29FEAC996AC159DE9, ConnectionId: 00000000000000000000000000000000, ConnectionCnt: 0

EPP TransactionId: 513BC209957E5597E10000000A6BA2FE

Error RFCIO_ERROR_SYSERROR in abrfcpic.c : 1730

CPIC-CALL: 'ThSAPOCMINIT' : cmRc=20 thRc=20

No storage allocation available

DEST =%_TCPIP_%1

HOST =svlixxca2

PROG =sapxpg

While I checked the RFC connection for SAPXPG_DBDEST_svlixxca2 , it says ERROR: user DDIC is not authorized to start TP sapxpg on host svlixxca2. How to rectify this RFC connection?

Can anyone help to solve this issue?

Thanks in advance!

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Mar 12, 2013 at 03:42 PM

    Hello

    Please check this note.

    Note 583759 - R/3 error when you start jobs from DB13

    Cheers

    RB

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Reagan Benjamin

      Hello Reagon,

      Thanks for your support. I solved the issue.

      Here is the background of problem:
      Since we have a distributed system where SAP central instance is installed on one server and DB instance is installed on another server so we need to do certain tasks at DB level but through SAP appliction itself for example db cleanup log, which should be done through background job which runs every Sunday to cleanup the old logs, since last couple of weeks it was failing. I wanted to troubleshoot it and as per analysis, the background job schedules at SAP application level which actually calls SAPXPG program .

      When the job was failing, there was an issue, so checked the RFC connection, (which points towards db server where the external program should execute) which installed during SAP installation, which says perform such tasks either with remote shell command or through gateway. We haven't installed standalone gateway on db servers so only option would be remote shell command.

      I pointed the SAP profile parameter gw/remsh=/usr/bin/ssh, and then checked the RFC connection, it was keep failing with error connection timed out, check partner availability. DB server was pinging and up.

      Another error, i found in another SAP log that permission denied so i doubted there must be something needs to improvise at OS, it must be asking password thats why connection got refused.

      I checked SSH svlixxca2 -l rd1adm sapxpg to check whether, at OS, it works or not. It asked password for rd1adm at svlixxca2 as doubted, correct. another issue noticed that after entering to svlixxca2, it says sapxpg command is not found so, this means it is not getting path.

      Changes made to correct the errors:
      1. Secure copied the .user_bash_profile of sidadm at svlixxca1 to svlixxca2 under /home/sidadm, which solved the issue, that command got the program SAPXPG at svlixxca2.
      2. To omit the password prompting during communication at SSH level, generated public and private keys using ssh-key-gen at svlixxca1 and copied ssh-copy-id to svlixxca2, which allowed sidadm to login on svlixxca2 without entering password.

      Now everything looks fine, and db13 jobs are running fine. Thanks everyone who tried to help me.

      Regards.

  • avatar image
    Former Member
    Mar 12, 2013 at 01:00 PM

    Hi,

    Have you tested this RFC with user other than DDIC? Could you please also paste error log of JOB or SM21 log?

    Thanks

    Sunny

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Sunny,

      This Note i have already checked, it doesn't say anything about RFC, i am surprised why RFC connection is not working, in fact if i call br tools at OS level with my ora<sid> user, it works fine.

      Do you shed some light on it?

      Regards, - vikas