Skip to Content
0

IDM8 - Users provisioning no more working after incidental "Initial load"

Jan 07, 2017 at 06:07 PM

72

avatar image
Former Member

Hi experts,

in our SAP IDM Productive system, after an unwanted execution of 'initia load' job for a specific repository, we are experiencing provisioning of users no more working (while provisioning of roles for existing users still works) for that specific repository. This repository link to an ABAP BI system (BW 740) using 'ABAPLoadBalancedConnection' connector.

If we manually create user on target system, provisoning of roles works as well.

Attached to this message you can find IDM system details.

Could you help us to restore the user provisioning function for that repository?

Thank you all !!

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member Jan 07, 2017 at 06:35 PM
0

system-info.txtinstalled-features-idm8.txtbwp001-initial-load-idm8.txt

sorry,

i cannot attach files to my original message, i am doing it here.

audit-log.jpg


Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi

I don't have IdM skills so my question might be pointless.... What is z_abap_mapUserid in your configuration? When you ran the initialization job could you have reset some type of counter which is causing issues with user creation?

Regards

Colleen

0
Former Member
Colleen Hebbert

Hi Colleen,

thanks for kind reply, I am attaching 2 pics of Z_ABAP_MAPUSERID where you can find an error.

Sorry, i am not an IDM expert, i am just a rookie :)

z-abap-mapuserid.jpg

z-abap-mapuserid-2.jpg

0
Deva Prakash B Jan 08, 2017 at 04:25 AM
0

Hello!!

As per screens shot attached i can see that account% attributes are not updated for that users. Please check and update the account attributes?

Apart from it from idm are you able to create new users in sap system with out any issues?

Is this issue occurred only for the existing users?

Regards,

DP

Show 4 Share
10 |10000 characters needed characters left characters exceeded
Former Member

thank you for your reply DP,

sorry, wich user do you mean we should update on account attributes?

So YES, is it possible to create a new user on target system without any issue;

and YES again, the issue only occurs for existing users, that's right.

thanks for help,

regards.

0

for all existing users update their ACCOUNT%$REPNAME% with their logonname which would be passed to SAP systems. this would solve your issue.

Regards,

DP

0
Former Member

Hi DP, maybe when you wrote "account% attributes" do you mean the "account privilege" for a target system referred to a user?

did i understood right?

thank you!

0

It is ACCOUNT%REPNAME% and i believe you system name would be BWP001.

Regards,

DP

0