Skip to Content
0

Another Target XSD requires a value for this element, ' Question

Jan 07, 2017 at 04:51 PM

66

avatar image

I've got an odd issue that I've taken too long with and would appreciate some help.

Very basic scenario: flat file > Proxy. Using FCC on sender adaptor.

Mapping: Structure mapping 1:1.

I've a very basic flat file (psv format), pipe delimited source file, its to be picked up via file adaptor and FCC, mapped directly to identical fields on a source dt / mt / si and passed to a xml file (later proxy).

Ive tried a multitude of dt / mt structures and still get very similar results. I've taken the XML from the Mesmon & put into message mapping to see where the error is (date field) yet when I put the xml in message mapping it fails here too, yet when I check the queue for the field its erroring on (date) it seems to work -but get a suppress in the queue, I've not knowingly suppressed any data. I've tried refreshing cache, after all rebuilds..

I've got an identical scenario that works OK. So am somewhat confused. Its bound to be something really small / silly but I cant see the wood for the tree's at present.

Images of setup:

source-dt.png

source-mt.pngdest-mt.pngsource-si.pngdest-si.pngmm.pngom.pngtest-file-and-fcc.pngmesmon-error.png

xml-in-mesmap.png

map-test-result-suppress.png

source-mt.png (24.7 kB)
dest-mt.png (24.9 kB)
source-si.png (26.2 kB)
dest-si.png (27.3 kB)
mm.png (42.7 kB)
om.png (35.6 kB)
mesmon-error.png (31.1 kB)
xml-in-mesmap.png (50.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Manoj K Jan 07, 2017 at 05:04 PM
0

George,

Its because the FCC XML and the expected XML in MM is not matching as a Extra node PayFile is getting added as a RecordSet observe the XML carefully.

Add this parameter in FCC , this will solve your issue:

ignoreRecordsetName = true

Br,

Manoj

Share
10 |10000 characters needed characters left characters exceeded
George Applegate Jan 08, 2017 at 02:26 PM
0

Many thanks Manoj.

Share
10 |10000 characters needed characters left characters exceeded