Skip to Content
author's profile photo Former Member
Former Member

Time out issue in CRM WEB UI

Hi,

We have an issue in CRM WEB UI,

In service contract header page for particular contarct type we are getting a "Time out message" for less than 7 minutes as

"Your session has timed out. Click here to start a new session. "

We tried with the follwing steps,

1.If we remove the user parameter "WCF_IGNORE_ENHANCEMT = A" (this profile

parameter refers to plain vanilla version of SAP webui ) on our user profile

(which I did now for ossuserrd), then timeout will not happen for 20, 25

minutes.

Could any one guide us to solve the above issue..

Regards,

S.Balaji

Add a comment
10|10000 characters needed characters exceeded

Related questions

7 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Mar 15, 2013 at 06:51 AM

    Check these profile parameters in RZ10

    rdisp/plugin_auto_logout


    icm/conn_timeout


    icm/keep_alive_timeout


    rdisp/keepalive_timeout


    rdisp/keepalive


    rdisp/gui_auto_logout

    and these notes

    633539
    1139596

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 08, 2013 at 05:27 PM

    Hi Balaji,

    I don't see any relation between the timeout issue and the parameter 'WCF_IGNORE_ENHANCEMT = A' unless there are some actions that keeps the session active for more time when the enchancement is enabled.

    Try to increase the timeout setting and see how it behaves in both the cases.

    Thanks & Best Regards,

    Leon

    Message was edited by: Leon Limson

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 09, 2013 at 01:36 AM

    I am not sure if I understood you correctly, there is a session time-out setting which you can set in SPRO, IMG>CRM>UI FRAMEWORK>Technical Role Definition>Define Technical Profile.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 09, 2013 at 04:24 AM

    Hi,

    In the Technical Role definition change the Max_Threshold value.

    Regards

    V CH Bharadwaj

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      hai,

      go to transaction RZ11 and change the parameter value

      rdisp/gui_auto_logout

      example: If it is 0, it means no logout occurs, if it is lets say 600, it means after 600 seconds of being idle, system auto logouts the user.

      please reward points

      regards

      sundarnukala

  • Posted on Mar 11, 2013 at 07:07 AM

    Hi Balaji,

    Try to take a ST05 trace for the contract type( which is taking more time ) and check where it is taking more time.

    Thanks

    Sudhansu

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 03, 2014 at 08:41 AM

    Hi Balaji,

    There are probably some exception raised in the backend and caught by UI framework. You can try to find the exact exception by following this link.

    Best regards,

    Jerry

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 04, 2014 at 12:49 AM

    Hi Balaji,

    Since the time out is not happening when you set the user parameter, "WCF_IGNORE_ENHANCEMENT" as 'A', it seems like the issue is something related to do with the custom enhancements made to Service Contract Header page. Review the custom enhancements made to the Service Contract Header page first. Set a breakpoint in the associated inbound plug method of the window controller and see if any exception is being thrown causing the system to time-out. Else set a breakpoint in the do_prepare_output method of the header view and see what is going on.

    Hope this helps.

    Regards,

    Prathap

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.