Skip to Content
avatar image
Former Member

Protocol cannot switch to https, so switch to https occurd

Dear All,

I am already configured the sso between ep portal 7.3 and backend system and sso working fine, when we create the webdynpro ABAP iview, it is successfully

created but when i am going to preview, it is showing error " Protocol cannot switch to Https, Https is not configured/active. No switch to Https occurred,

so it is not secure to send a password"

Please find the attached screen shot for your reference , suggest me....

Regards,

Shashank

Untitled.jpg (97.9 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Apr 11, 2014 at 09:26 AM

    Hi Kumar,

    is not an error message but an informational message, which is shown
    when the integrated ITS is called with HTTP.

    So the message is no longer shown if the ITS is called with HTTPS or if
    you change the settings in transaction SICF. There you have a checkbox
    "Show no warnings" in the settings of the system logon.

    Go ahead as described in SAP note:
    #510007
    This is very important, the SSL is requiered to generate the
    MYSAPSSO2 cookie.

    Make sure the following profile parameters are in your default profile:
    login/accept_sso2_ticket=1
    login/create_sso2_ticket=1 or 2

    These paramters will make your system to create and accept these
    cookies.

    Restart the system after the changes.

    Best Regards

    Mohammed

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 06, 2013 at 12:05 PM

    hi shashank,

    Either the redirect to HTTPS was suppressed manually by setting the No switch to HTTPSparameter on the configuration screen of the ICF node, or the server’s SSL configuration is incorrect. In the ICM Monitor – Service display, check the status of the HTTPS protocol and, if necessary, contact your administrator

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 06, 2013 at 11:22 AM

    I think this happens when from a secure connection, you are switched to non secure connection

    Are you accessing the portal via https?

    Please check your backend ABAP system if it has

    Https enabled and active via tx smicm

    Also check your system landscape object that you have the WAS connection

    Pointing to https

    You may also try if sso works with http

    In that case access portal using its http port

    And check system landscape WAS connection is also http

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 05, 2015 at 10:40 AM
    Add comment
    10|10000 characters needed characters exceeded