Skip to Content
author's profile photo Former Member
Former Member

Proxy - PI to ECC - message not coming to ECC -Error Parsing PI Response

Hi All,


Scenario is PI proxy message is reciving from ECC, but connection test from PI to ECC not work.

The user PIISUSER is correct. SLD ia working.

I have this Response Text from SM59.

HTTP/1.0 500 Empty HTTP request received

Content-Type: text/xml

Content-Length: 815

content-id: <soap-51351C81FD6941CFE10000000A4BE920@sap.com>

soapaction: 'http://sap.com/xi/XI/Message/30'

server: SAP Web Application Server (1.0;700)

<SOAP:Envelope xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/">

<SOAP:Header>

</SOAP:Header>

<SOAP:Body>

<SOAP:Fault xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/"><faultcode>SOAP:Client</faultcode><faultstring>Empty HTTP request received</faultstring><faultactor>http://sap.com/xi/XI/Message/30</faultactor><detail><SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1"><SAP:Category>XIProtocol</SAP:Category><SAP:Code area="MESSAGE">EMPTY_HTTP_REQUEST_RECEIVED</SAP:Code><SAP:P1/><SAP:P2/><SAP:P3/><SAP:P4/><SAP:AdditionalText/><SAP:ApplicationFaultMessage namespace=""/><SAP:Stack>Empty HTTP query received; message processing not possible

</SAP:Stack></SAP:Error></detail></SOAP:Fault>

</SOAP:Body>

</SOAP:Envelope

Pleas help me on it.

Thanks

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Mar 06, 2013 at 09:16 AM

    Hi Ejersbo,

    This is really an error, this is the typical response you get when doing a connection test on an HTTP type destination from SM59.

    Have you checked the normal things like:

    - SXMB_MONI in PI

    - SMQ2 in PI

    etc to see where the messages are getting stuck?

    Regards, Trevor

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 06, 2013 at 09:28 AM

    Hello,

    The response from the SM59 destination test of type H is normal. It would really return a 500 because you sent an empty HTTP Body, but aside from that, the connection is working. What is the error that you are getting?

    Regards,

    Mark

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 06, 2013 at 09:35 AM

    Nothing wrong with it. Connection is successful.

    You are sending an empty call, test it by sending an ABAP Proxy message.

    It will work.

    Thanks

    Sunil

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.