Skip to Content
-2

table control in module pool

Jan 07, 2017 at 06:52 AM

138

avatar image

hi ,

i want to remove v-scrollbar in table control with wizard ,i can't see any option in table control properties, is it possible do.

thanks in advance .

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Sandra Rossi Jan 07, 2017 at 08:43 AM
1

I guess it's not possible with table controls. The maximum you can do is to remove the cursor inside the vertical scrollbar (component LINES of the CONTROLS structure), nothing more.

If you really want a table without vertical scrollbar, you should replace the table control with a custom container containing an ALV grid.

Share
10 |10000 characters needed characters left characters exceeded
Pablo Casamayor Jan 09, 2017 at 09:02 AM
1

Hi,

maybe once the table control is created with the wizard you could try switching off horizontal and vertical scrolling in the properties of the table control.

Best regards,

Pablo

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Pablo Casamayor,

No option for horizontal and vertical scrolling table control with wizard properties.

Thanks.

Raja

0

Hi,

i was referring to "once the table control is created with the wizard" not while executing the wizard.

e.g. (see screenshots attached)

precisely in here:

you could try to untick the vertical option there.

Best regards,

Pablo

tc1.png (43.1 kB)
tc3.png (1.1 kB)
0
Richard Harper Jan 09, 2017 at 08:21 AM
0

I'm not on an SAP system at the moment, however, within a table control is a structure that defines what the control looks like. Have a look at this and you might find what you are looking for. You can then modify these values in the PBO.

Rich

Share
10 |10000 characters needed characters left characters exceeded
umayaraj B Jan 11, 2017 at 08:25 AM
0

Hi Pablo Casamayor,

Thanks for quick reply but i all ready try option this option in table control with wizard properties, actually this option for only resizing full table size not for scroll bar,i want remove scrollbar .

Thanks.

Raja

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi,

after doing some tests i confirm that the above does not work.

The only solution i see here is to comment the code (when P--, P-, P+, P++) of routine user_ok_tc in the corresponding pai module.

Best regards,

Pablo

0

Hi,

in the tablecontrol wizard there was this option Scroll

did you try to untick it so as not to create the scrolling options?

Best regards,

Pablo

tc4.png (55.0 kB)
0

Hi,

i confirm that unticking the above scroll option does not work so as to avoid vertical scrolling (you would only avoid page scrolling).

The only option i see is what Sandra Rossi proposed in her answer.

Best regards,

Pablo

0