Skip to Content

SP12 error: MUT-02041 SDM call of deploySdaList ends with returncode 4

Dears,

I have SAP Developer Workplace installed on a local WindowsXP PC (with 1 GB RAM). I had it running with SP9 with no problem. Since our portal went to SP12 I also wanted to upgrade to SP12. On another PC it went thorugh with no error, but on this it stopped at approx. step 14 with:

MUT-02041 SDM call of deploySdaList ends with returncode 4.See output of logfile C:\Program Files\sapinst_instdir\PATCH\ADA\callSdmViaSapinst.log.

See log info below.

I already started the SDM via StartServer.bat

I also set the SDM startup mode to integrated with

sdm jstartup "mode=integrated"

The Administrator password for SDM is ok, since I can log on to the SDM via RemoeGui.bat with it.

It seems that during SP12 installation process the SDM java process is stopped and althoughI start it manually it does not deploy a file called SAPJTECH......SCA.

Has anyone alread had the same problem?

regards

Ulf

-


callSdmViaSapinst.log----


Aug 16, 2005 2:35:14 PM Info: Start logging to console

Aug 16, 2005 2:35:14 PM Info:

Aug 16, 2005 2:35:14 PM Info: ============================================

Aug 16, 2005 2:35:14 PM Info: = Starting to execute command 'deploy' =

Aug 16, 2005 2:35:14 PM Info: ============================================

Aug 16, 2005 2:35:14 PM Info: Starting SDM - Software Deployment Manager...

Aug 16, 2005 2:35:15 PM Info: tc/SL/SDM/SDM/sap.com/SAP AG/6.4012.00.0000.20050502115929.0000

Aug 16, 2005 2:35:15 PM Info: SDM operation mode successfully set to: Integrated

Aug 16, 2005 2:35:16 PM Info: Initializing Network Manager (50017)

Aug 16, 2005 2:35:16 PM Info: Checking if another SDM is running on port 50018

Aug 16, 2005 2:35:16 PM Error: SDM is integrated in JStartupFramework. No repository changing commands are possible.

Aug 16, 2005 2:35:16 PM Error: Processing error. Return code: 4

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Sep 24, 2005 at 12:42 PM

    Hi Ulf,

    I am having exactly the same problem installing SP13 for

    SAP J2EE Engine 6.40. Did you find a solution?

    Regards,

    Yuri

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 26, 2005 at 08:48 AM

    Hi,

    we finally managed to uninstall it and install it again with the SAPInst that came with SP12.

    It just did not acceptour MAxDB version and we had to download one or two CD'S from the serviceplace.

    KR

    Ulf

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.