Skip to Content
0

Database Configuration options not available for Crystal in CMC

Jan 06, 2017 at 08:55 PM

57

avatar image

In the CMC, we right click on a Crystal Report and choose Database Configuration. I want to set the option 'When viewing and scheduling report:', but this option is grayed out. I want to set it to 'Use same database logon as when report is run', but it shows 'Use SSO context for database logon (viewing only)' and won't let me change it. How can I make this field editable?

FYI - We installed a fresh copy of 4.2 SP3 and migrate a few reports from 4.1 using Promotion manager. The migrated reports in 4.2 are the ones we are experience the issue on. They are Ok in 4.1.

Thanks, Chris

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Chris Robertson Jan 18, 2017 at 09:46 PM
0

This is resolved. SAP Note 1595992.

Share
10 |10000 characters needed characters left characters exceeded
Dell Stinnett-Christy Jan 09, 2017 at 06:02 PM
0

What type of database connection is the report using in Crystal itself? Was it set up to use "Integrated security" on the connection? If it was, you won't be able to change this in the CMC without updating the report to use a manual login on its connection.

-Dell

Show 1 Share
10 |10000 characters needed characters left characters exceeded

It only happens for the reports to an SAP source: BW or ECC. Those that attach to SQL server have this options available. I'm not familiar with integrated security. I'll look a little closer to see if that could help us figure that out.

Thanks.

0
Don Williams
Jan 09, 2017 at 11:23 PM
0

Are you an administrator on the BOE System?

I changed the main tag to BOE, it may be a migration issue also.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Yes. I'm signed on with an administrator ID.

Thanks for the proper tag update.

0