Skip to Content
avatar image
Former Member

Error with 7.1 SP6 to 7.2 SP6 upgrade - Upgrade Repositories job

Hi there,

We are part way through upgrading IDM 7.1 SP6 to IDM 7.2 SP6 and have successfully imported the new 7.2 SAP Provisioning Framework as per the Identity Management for SAP System Landscapes: Upgrading from Identity Management 7.1 to 7.2 (page 23 - step 8)

When trying to run the 2nd of the jobs to upgrade the repositories from 7.1 to 7.2 (called 2. Upgrade Repositories in Identity Center) we encounter the following error:

Executing sap_open_rep_def(E:\usr\sap\<SID>\IdM\Identity Center) got RuntimeException - org.mozilla.javascript.EvaluatorException: Class org.mozilla.javascript.NativeJavaMethod can not access a member of class org.apache.crimson.tree.ParentNode with modifiers "public final" HINT: Check line 19 in the script sap_open_rep_def

I have tried moving one of the files from the E:\usr\sap\<SID>\IdM\Identity Center\Templates\Identity Center\Repositories folder to another location and get an error message that the file I have deleted was not found, so I have confirmed that the filesystem is able to be accessed by the script. I have moved the file back into this folder.

Line 19 in the script looks like this:

repname=repdef[iiv];

We are running IDM on SQL Server 2005 SP3.

Any ideas on what the problem might be would be greatly appreciated.

Regards,

Mark

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Feb 28, 2013 at 10:17 AM

    Hi Mark,

    i'm having the same problem, updating IDM 7.1 sp3 to 7.2 sp7 on oracle 10. did you find a solution? did you open an oss message?

    BR,

    Clotilde

    Add comment
    10|10000 characters needed characters exceeded