Skip to Content
avatar image
Former Member

SOST mails transmission issue

Dear All,

I am having issue with sending mails from 2 application servers, where SMTP is showing not active (but External Bind is active) even after adding " icm/server_port_1 = PROT=SMTP,PORT=24,EXTBIND=1 " in 2 application server instances.

(fyi: icm/server_port_0 parameter is already set active in all instances)

Followed the below link for doing the above activity.

http://scn.sap.com/community/netweaver-administrator/blog/2012/08/13/sost-mails-transmission-issue-blog-2

Failed reason is same :

Cannot process message in SAP System

Message no. XS817

Diagnosis

Processing could not be continued due to a technical or configuration error in the SAP system.

System Response

Processing was terminated.

Procedure

Processing was terminated in the SAP system. The reason is given in the details below:

No ESMTP Plug-In Is Available for SAPconnect

Application Server Used by the Send Process:

xxxxxxxxx

(Schedule Send Process on App.Server with Plug-In)

As per SAP Note : 757804, rdisp/start_icman = true parameter already exist in " Default " profile. Even though I have added this parameter in one of application server instance and restarted the same.

When i try to activate the SMTP in SMICM, error is same " Operation failed (rc=1) with Message no. ICM006 ".

Request someone please help on this issue for smooth functioning of sending mails. If any settings / parameters needs to be set/checked please suggest

Rgds,

Durga

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Feb 15, 2013 at 10:57 AM

    Hello,

    Can you check if you are able to connect to the mailhost from the application servers from where the mails are not working.

    telnet <mail-host> <mail-port>

    For <mail-host> and <mail-port>, specify the values entered in the SAPconnect SMTP node (usually 25 for <mail-port>).

    Check and confirm back.

    Regards,

    Mudasir

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Deepak Kori

      Deepak,

      Thank you for the hint. I have changed to port 25000 for SMTP and it works fine after bouncing the application once. Also infact my OP link itself is an answer.

      Before that i tried with just 25 and it did't work.

      Rgds,

      Durga

  • Feb 15, 2013 at 09:11 AM

    Hi Durga,

    Ensure the following

    1) SMTP port shows active in smicm for the application servers as well as CI server. Default port for SMTP is 25.

    2) Once step 1 is done, ensure that SMTP relaying is allowed for all the SAP server ip addresses into your mail server settings.

    Regards,

    Deepak Kori

    Add comment
    10|10000 characters needed characters exceeded